X
Tap here to go to the mobile version of the site.

منتدى الدعم

Site does not display properly in Firefox, It is OK in IE, Opera, Chrome, and Safari for Windows

Posted

Example: https://www.stuftpizzabarandgrill.com/catering/ AND MANY OTHERS

Pages do not display properly and are difficult or impossible to read only in FF. This is a regular problem on many sites, not just this one.

In this particular page, FF displays black text on a very dark gray background. I just checked it in IE, Chrome, Opera, and Safari for Windows and they all show white text, making it readable.

This is obviously a problem with the way FF displays pages and ONLY FF.

Using Vista but that should not be an issue. All the other browsers checked show the page properly.

Example: https://www.stuftpizzabarandgrill.com/catering/ AND MANY OTHERS Pages do not display properly and are difficult or impossible to read only in FF. This is a regular problem on many sites, not just this one. In this particular page, FF displays black text on a very dark gray background. I just checked it in IE, Chrome, Opera, and Safari for Windows and they all show white text, making it readable. This is obviously a problem with the way FF displays pages and ONLY FF. Using Vista but that should not be an issue. All the other browsers checked show the page properly.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 23.0 r0
  • 5.1.50906.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Question owner

waynec444 said

cor-el said
For Google there is this WebExtension:

Did this. Not only did it not work, now my Google search results are in very large text. Disabling the add-on did not fix it. I want the text size to go back to what it was. ONLY Google search text results size is larger. Everything else seems to be normal as it was before.

I just noticed that other pages now have hugely oversized text too. Not just the Google results listings.

''waynec444 [[#answer-1009422|said]]'' <blockquote> ''cor-el [[#answer-1009272|said]]'' <blockquote> For Google there is this WebExtension: *Custom Google Visited Link Color:<br>https://addons.mozilla.org/en-US/firefox/addon/google-link-color/ </blockquote> Did this. Not only did it not work, now my Google search results are in very large text. Disabling the add-on did not fix it. I want the text size to go back to what it was. ONLY Google search text results size is larger. Everything else seems to be normal as it was before. </blockquote> I just noticed that other pages now have hugely oversized text too. Not just the Google results listings.

Question owner

waynec444 said

cor-el said
For Google there is this WebExtension:

Did this. Not only did it not work, now my Google search results are in very large text. Disabling the add-on did not fix it. I want the text size to go back to what it was. ONLY Google search text results size is larger. Everything else seems to be normal as it was before.

Text size problem finally found and fixed.

''waynec444 [[#answer-1009422|said]]'' <blockquote> ''cor-el [[#answer-1009272|said]]'' <blockquote> For Google there is this WebExtension: *Custom Google Visited Link Color:<br>https://addons.mozilla.org/en-US/firefox/addon/google-link-color/ </blockquote> Did this. Not only did it not work, now my Google search results are in very large text. Disabling the add-on did not fix it. I want the text size to go back to what it was. ONLY Google search text results size is larger. Everything else seems to be normal as it was before. </blockquote> Text size problem finally found and fixed.

Question owner

I have an idea. Is it possible to keep the Options/Colors Link Colors option and changeable but disable the Text and Background Colors option (I will NEVER want to enable that option)?

In other words, disble the option to enable the the Text and Background Colors but allow the changing of the link colors when clicking on OK. Right now they are linked and when changing the link colors it is "required" to also enable the text and background colors. It makes many sites unreadable. Actually, these two settings SHOULD have been separated and not connected with each other. They are completely different.

I have an idea. Is it possible to keep the Options/Colors Link Colors option and changeable but disable the Text and Background Colors option (I will NEVER want to enable that option)? In other words, disble the option to enable the the Text and Background Colors but allow the changing of the link colors when clicking on OK. Right now they are linked and when changing the link colors it is "required" to also enable the text and background colors. It makes many sites unreadable. Actually, these two settings SHOULD have been separated and not connected with each other. They are completely different.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157849 answers

You can use a :visited rule in userContent.css to override such a rule added by a website.

For a specific domain use:

@-moz-document domain(google.com){
 :visited {color: red !important}
}

You can enter a default value to be used always and if necessary (issues with the background color)override the default.

 :visited {color: magenta !important}

@-moz-document domain(google.com){
 :visited {color: red !important}
}

You can also consider to set a box-shadow to override the background color.


You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userContent.css file in the editor window
  • make sure that the userChrome.css file starts with the default @namespace line
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
You can use a :visited rule in userContent.css to override such a rule added by a website. For a specific domain use: <pre><nowiki>@-moz-document domain(google.com){ :visited {color: red !important} }</nowiki></pre> You can enter a default value to be used always and if necessary (issues with the background color)override the default. <pre><nowiki> :visited {color: magenta !important} @-moz-document domain(google.com){ :visited {color: red !important} }</nowiki></pre> You can also consider to set a box-shadow to override the background color. *https://developer.mozilla.org/en-US/docs/Web/CSS/:visited *https://developer.mozilla.org/en-US/docs/Web/CSS/box-shadow?v=b ---- You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox *create the <b>chrome</b> folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *use a plain text editor like Notepad to create a (new) <b>userContent.css</b> file in the chrome folder (file name is case sensitive) *paste the code in the userContent.css file in the editor window *make sure that the userChrome.css file starts with the default <u>@namespace line</u> *make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.<br>otherwise Windows may add a hidden <i>.txt</i> file extension and you end up with a not working <i>userContent.css.txt</i> file *http://kb.mozillazine.org/userContent.css