X
Tap here to go to the mobile version of the site.

منتدى الدعم

google.com more option (Google Apps) not working

Posted

From couple of weeks I am noticing that option for more apps (the grid icon on google main page) is not working in firefox but it works with internet explorer. This option works very well at my office in the same firefox version. I have also same addons installed at office and home (Add blocker plus, no script, download them all, video download helper). I tried updating firefox on latest version and also create new firefox profile but it does not solve this issue. i want to identify and solve this problem because this also affects for getting option to logout from gmail (that is also not working in my home using firefox). I am attaching the image for the option I am asking about. I will appreciate if anyone can help.

From couple of weeks I am noticing that option for more apps (the grid icon on google main page) is not working in firefox but it works with internet explorer. This option works very well at my office in the same firefox version. I have also same addons installed at office and home (Add blocker plus, no script, download them all, video download helper). I tried updating firefox on latest version and also create new firefox profile but it does not solve this issue. i want to identify and solve this problem because this also affects for getting option to logout from gmail (that is also not working in my home using firefox). I am attaching the image for the option I am asking about. I will appreciate if anyone can help.
Attached screenshots

Modified by KashifSurhio

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • McAfee MSC FF plugin DLL
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin

Application

  • Firefox 45.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DownThemAll! 2.0.18.1-signed.1-let-fixed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • Image Zoom 0.6.3.1-signed ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • NoScript 2.9.0.4 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Password Exporter 1.3.1.1-signed ({B17C1C5A-04B1-11DB-9804-B622A1EF5492})
  • Print pages to PDF 0.1.9.3.1-signed (printPages2Pdf@reinhold.ripper)
  • Video DownloadHelper 5.4.2 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 5500
  • adapterDescription2:
  • adapterDeviceID: 0x1616
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 390b17aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18123
  • driverDate: 12-15-2015
  • driverDate2:
  • driverVersion: 20.19.15.4352
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Helpful Reply

Any response from FF technical team??

Any response from FF technical team??
jscher2000
  • Top 10 Contributor
8788 solutions 71867 answers

Sorry for the delay!

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

Sorry for the delay! Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any difference?

Question owner

Hi jscher2000,

First thanks for your response here.

I tried what you recommend (Help menu > Restart with Add-ons Disabled) and start Firefox in Safe Mode but there is no difference, still the google apps script is not working. I have double check that all my add-ons are disabled.

Any other way to find the problem like to get firefox logs or anything that may help devs identify this issue.

Attaching the image where the apps works fine in IE but not in FF

Regards Kashif

Hi jscher2000, First thanks for your response here. I tried what you recommend (Help menu > Restart with Add-ons Disabled) and start Firefox in Safe Mode but there is no difference, still the google apps script is not working. I have double check that all my add-ons are disabled. Any other way to find the problem like to get firefox logs or anything that may help devs identify this issue. Attaching the image where the apps works fine in IE but not in FF Regards Kashif
jscher2000
  • Top 10 Contributor
8788 solutions 71867 answers

Does your computer have a touchscreen? Occasionally Firefox users report that some interface elements are non-operable with a mouse on Windows 8 but are operable with a touch. Usually we haven't found a way to fix this issue in Firefox, although these past thread mention some changes to try:

Does your computer have a touchscreen? Occasionally Firefox users report that some interface elements are non-operable with a mouse on Windows 8 but are operable with a touch. Usually we haven't found a way to fix this issue in Firefox, although these past thread mention some changes to try: * [https://support.mozilla.org/questions/1042114 Websites that use java are not working.] - resolved by disabling touch at the Windows level * [https://support.mozilla.org/questions/986902 mouse hover drop down menu not shown] - resolved by disabling touch at the Windows level * [https://support.mozilla.org/questions/971084 Javascript menus don't work.] - similar problems in Google Chrome and Firefox with HP All-in-One system, resolved by disabling touch at the Windows level * [https://support.mozilla.org/questions/961224 When trying to click on menus on USAA, it shows "javascript:;" in the bottom left hand corner and the menu won't work in FF 21.] - resolved by disabling a preference in Firefox

Question owner

Hi jscher2000,

No my laptop is not with touch screen, I am using Lenovo G50-80, Core i5, 4GB RAM standard configuration.

I also refreshed the FF (I have all the add-on backup with me) but issue is not resolved.

PS, I don't have a mouse so I am using touch pad. I've also tried using my Android as mouse but same issue.

Hi jscher2000, No my laptop is not with touch screen, I am using Lenovo G50-80, Core i5, 4GB RAM standard configuration. I also refreshed the FF (I have all the add-on backup with me) but issue is not resolved. PS, I don't have a mouse so I am using touch pad. I've also tried using my Android as mouse but same issue.

Modified by KashifSurhio

jscher2000
  • Top 10 Contributor
8788 solutions 71867 answers

As the next step, could you check two of Firefox's Developer Tools?

On the Google home page, right-click the non-working icon and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab with the active element highlighted. I am attaching a screenshot for comparison. Does yours show that the active element is the link and does it also show the little "EV" indicator at the end of the link showing that scripts are assigned to this link?

Next, click the Console button along the top edge of the developer tools. To remove existing clutter in the console, click the Clear button above the list, and then try the apps/menu button and check for any error messages in the console. I have attached a screenshot for reference (without errors). Anything?

As the next step, could you check two of Firefox's Developer Tools? On the Google home page, right-click the non-working icon and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab with the active element highlighted. I am attaching a screenshot for comparison. Does yours show that the active element is the link and does it also show the little "EV" indicator at the end of the link showing that scripts are assigned to this link? Next, click the Console button along the top edge of the developer tools. To remove existing clutter in the console, click the Clear button above the list, and then try the apps/menu button and check for any error messages in the console. I have attached a screenshot for reference (without errors). Anything?

Question owner

Please check attached images.

Please check attached images.
jscher2000
  • Top 10 Contributor
8788 solutions 71867 answers

Hi KashifSurhio, there definitely is a problem in the first screen shot if the actual menu content is not in the document at all. I really have no idea why that is missing, since in my limited testing it is being sent by the server as part of the page.

Is there anything special about how your home Firefox connects to the network, for example, a proxy server, private VPN, Tor, Hola, or being "filtered" by security software?

You could check your Firefox connection settings here:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that makes a difference.

Hi KashifSurhio, there definitely is a problem in the first screen shot if the actual menu content is not in the document at all. I really have no idea why that is missing, since in my limited testing it is being sent by the server as part of the page. Is there anything special about how your home Firefox connects to the network, for example, a proxy server, private VPN, Tor, Hola, or being "filtered" by security software? You could check your Firefox connection settings here: "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button. The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that makes a difference.

Question owner

Hi jscher2000,

I change network proxy to o proxy and check the page but it is same as before. For your question, I am using my mobile internet with wlan sharing (connection from Vodafone Qatar) the thing only in my mind is, if the options are not connected with page then it should also not work with internet explorer. May be my telco filter the data and sends in last that Firefox is not getting successfully or not understanding.

Hi jscher2000, I change network proxy to o proxy and check the page but it is same as before. For your question, I am using my mobile internet with wlan sharing (connection from Vodafone Qatar) the thing only in my mind is, if the options are not connected with page then it should also not work with internet explorer. May be my telco filter the data and sends in last that Firefox is not getting successfully or not understanding.
jscher2000
  • Top 10 Contributor
8788 solutions 71867 answers

Hi KashifSurhio, is there any reason that scripts might be blocked from running on that page? If I block scripts, I don't get event handlers (makes sense, since those are scripts) but also the menu HTML is in a location much further down the document as shown in the attached screenshot.

Hi KashifSurhio, is there any reason that scripts might be blocked from running on that page? If I block scripts, I don't get event handlers (makes sense, since those are scripts) but also the menu HTML is in a location much further down the document as shown in the attached screenshot.

Question owner

Hi jscher2000,

I randomly perform some tests and found something interesting (see attached images) as:

1> With the help of no script add-on I disable all scripts for google.com.pk 2> I open news from google old style menu (with no java script support) 3> Noticed the URL with js=0 (java script disabled) 4> From noScript add-on Temporarily allow all on this page (news.google.com.pk) 5> Page auto refreshed and "js=0" is removed (Because scripts are temporarily allowed) 6> Google Apps scripts are working now

If something is blocked by FF itself - I don't have any idea. Something blocked by any other app (Antivirus, Firewall, or telco service provider itself) - IE should also not work in this case but this does not seems to be any issue

Hi jscher2000, I randomly perform some tests and found something interesting (see attached images) as: 1> With the help of no script add-on I disable all scripts for google.com.pk 2> I open news from google old style menu (with no java script support) 3> Noticed the URL with js=0 (java script disabled) 4> From noScript add-on Temporarily allow all on this page (news.google.com.pk) 5> Page auto refreshed and "js=0" is removed (Because scripts are temporarily allowed) 6> Google Apps scripts are working now If something is blocked by FF itself - I don't have any idea. Something blocked by any other app (Antivirus, Firewall, or telco service provider itself) - IE should also not work in this case but this does not seems to be any issue
jscher2000
  • Top 10 Contributor
8788 solutions 71867 answers

Helpful Reply

Nothing else is coming to mind for me. If you think this started with the Firefox 45 update, and since you already tried a new profile, possibly there is some corruption in the program folder. That can be the thing to check after running out of logical explanations...

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 45.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version.

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(32-bit Firefox on 64-bit Windows)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(Other systems)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Also, has your NoScript updated to version 2.9.0.10? There were some bug fixes recently, although I don't think they relate to Google sites.

Nothing else is coming to mind for me. If you think this started with the Firefox 45 update, and since you already tried a new profile, possibly there is some corruption in the program folder. That can be the thing to check after running out of logical explanations... '''''Clean Reinstall''''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (A) Download a fresh installer for Firefox 45.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) '''For maximum plugin compatibility, choose the 32-bit version.''' (B) Exit out of Firefox (if applicable). (C) Rename the program folder as follows: ''(32-bit Firefox on 64-bit Windows)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(Other systems)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Any improvement? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins ---- Also, has your NoScript updated to version 2.9.0.10? There were some bug fixes recently, although I don't think they relate to Google sites.

Question owner

Hi jscher2000,

First "YES" I have updated version of NoScript i-e 2.9.0.10

Now, I did what you mention in Clean Install, along with Mozilla Firefox I also renamed Mozilla Maintenance Service and then perform clean install of version 45.0.1 but no luck, issue is same. Second today I tried with my old backup of Tor Browser 24.4.0 and it is working fine. Then I download latest TOR Bundle (it shows based on FF 38.7.1) and google is working fine. To my normal FF (45.0.1) I enable global scripts from NoScript and open google.com.pk but the issue is not resolved.

Hi jscher2000, First "YES" I have updated version of NoScript i-e 2.9.0.10 Now, I did what you mention in Clean Install, along with Mozilla Firefox I also renamed Mozilla Maintenance Service and then perform clean install of version 45.0.1 but no luck, issue is same. Second today I tried with my old backup of Tor Browser 24.4.0 and it is working fine. Then I download latest TOR Bundle (it shows based on FF 38.7.1) and google is working fine. To my normal FF (45.0.1) I enable global scripts from NoScript and open google.com.pk but the issue is not resolved.