Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

no sound and volume icon suddenly has red x

  • 3 replies
  • 2 have this problem
  • 233 views
  • آخر ردّ كتبه FredMcD

more options

Everything was working last night, but I noticed this morning there is no sound and my volume icon has a small red X on it. I've looked up the articles on Mozzila Support and Community Questions and think I have tried them all. No luck. Running Win 7 (tried 10 and will put off reloading it as long as possible) with Firefox.

Chosen solution

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

The sound started working and red X disappeared after turning 'puter off for awhile. I should have thought of that earlier. Thanks for the links, tho. I've used a couple before but will keep them for reference.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.