ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Typing "amazon <some string>" in the url bar always searches "some string" at amazon.com

  • 9 ردود
  • 1 has this problem
  • 591 views
  • آخر ردّ كتبه FredMcD

more options

I just noticed that when I type "amazon" on the location bar - it takes me to amazon.com, and if I type "Amazon <anything>" it takes me to the amazon search results.

I can reproduce this in safe mode on OS X Yosemite, Firefox 38.

How do I disable this behavior?

Edit: I just realized that this happens for my other search engines as well. If I type "duckduckgo is a good browser" it searches ddg for "is a good browser". Why does it do this and how can I disable it?

Modified by varunkvv

الحل المُختار

For what it's worth, that doesn't happen for me on Windows.

Firefox does have another "keyword" feature that would let you specify something short like g for Google or y for Yahoo to specifically send address bar searches to a particular search engine. It's possible that you somehow got keywords assigned to your search engines. To check that, you need to call up a hidden configuration page by pasting the following in the address bar and pressing Enter:

chrome://browser/content/search/engineManager.xul

Read this answer in context 👍 1

All Replies (9)

more options

<deleted>

Modified by varunkvv

more options

When you type one word in the address bar, the browser first checks to see if it is a web link, as Amazon + .com is. For one word searches, you should use the search bar instead.

more options

Thanks for your reply FredMcD. The problem is that the search query "Amazon removed 1984 from kindle" searches amazon.com for "removed 1984 from kindle". What I expect is it would search the whole thing on my default search engine (which is google).

I don't want firefox to try and be smart about which site I want to search.

I updated my title to make my issue a little clearer.

Modified by varunkvv

more options
more options

cor-el - the second link you posted has certain instructions which would supposedly fix this issue, however it does not for me.

Specifically, it suggests setting "keyword.enabled" to false in about:config.

This does not work though - typing "amazon kindle" still takes me to amazon.com.

Does nobody else have this issue on their firefox? Perhaps it's better to submit this as a bug?

Modified by varunkvv

more options

الحل المُختار

For what it's worth, that doesn't happen for me on Windows.

Firefox does have another "keyword" feature that would let you specify something short like g for Google or y for Yahoo to specifically send address bar searches to a particular search engine. It's possible that you somehow got keywords assigned to your search engines. To check that, you need to call up a hidden configuration page by pasting the following in the address bar and pressing Enter:

chrome://browser/content/search/engineManager.xul

more options

Actually, there's another place to possibly find "smart keyword" search associations and that is in your bookmarks. I can't figure out a way to search for them, however. Hmm...

more options
more options

I don't know what gives, but the link above was not the link I wanted.

https://support.mozilla.org/en-US/search?esab=a&w=1&q=keyword

Okay, this one is.