ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ниспадающее меню поля поиска

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 2 views
  • آخر ردّ كتبه cor-el

more options

Подскажите пожалуйста как настроить ниспадающее меню поля поиска на новой вкладке. Проблема в том, что там должны отображаться мои предыдущие запросы, но отображаются не все, а только два. Причем выборка происходит странно. Одним словом не могу разобраться как сделать чтобы отображалось то что я раньше вводил в поисковую строку.

Подскажите пожалуйста как настроить ниспадающее меню поля поиска на новой вкладке. Проблема в том, что там должны отображаться мои предыдущие запросы, но отображаются не все, а только два. Причем выборка происходит странно. Одним словом не могу разобраться как сделать чтобы отображалось то что я раньше вводил в поисковую строку.

All Replies (2)

more options

Is this what you are looking for? If not, let us know.

If you want to restore the previously used standalone window to manage search engines then you can toggle this pref to false with a middle-click on the about:config page.

about:config page: browser.search.showOneOffButtons = false

You need to close and restart Firefox to make this work properly.


In the address bar, type about:preferences#search<enter>

If you miss being able to switch search engines without going crazy with menus, try this out;

Context Search {web link} Expands the context menu's 'Search for' item into a list of installed search engines, allowing you to choose the engine you want to use for each search.

more options

You only see two suggestions of search terms that you typed if Firefox also displays suggestions provided by the search engine website. I see the full list if I press the Down key without having typed anything.

If you want to see more typed search terms all the time then you can disable the suggestions via "Change Search Settings" (Options/Preferences > Search)

I don't know what happens if the suggestions aren't working properly for some reason or if the selected search engine doesn't provide search suggestions.

Modified by cor-el