Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hierdie gesprek is in die argief. Vra asseblief 'n nuwe vraag as jy hulp nodig het.

How do I disable the "Check forUpdates" Feature\Button in Help-About?

  • 4 antwoorde
  • 7 hierdie probleem
  • Laaste antwoord deur baillard

more options

We are a large Government enterprise entity, over 5000 devices. Is an IT technical administrator, we need to gain complete control over updates through our enterprise distribution tools, we do not want users doing any updates. I have already done all the config tweaks to disable automatic updates, but those do not disable the "Check for Updates" feature\button in Help - About. How do I also disable that feature?

I realize Mozilla has come out and basically blown off requests to develop an enterprise version that has an "IEAK" if you will. That will ultimately keep you from exploiting all large enterprises, including Government. We currently only allow FF on 300 devices out of 5000 only for some specific applications. If you had a more enterprise friendly version that could be easily locked down, configured and deployed via an administrative kit, FF might be our default browser, but until then, IE will rule the enterprise market as a default browser, especially in Government enterprises.

All Replies (4)

more options

You can lock the related app.update pref(s)

You can use these functions in mozilla.cfg:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes

See also:

more options

Thanks, but I already have the two items below locked down, they have no impact on the "Check for Updates" button in Help - About. Any other ideas? That feature must be located somewhere... app.update.enabled

more options

Maybe lock the app.update.url pref to an empty string.
Then Firefox can't check for updates.

There is an #adminDisabled hbox present in that part of the about window, but I don't know how to make that display.

more options

Not a direct solution, but join the Enterprise Working Group, reactived 3-4 months ago Next confernce call Thu 2011-10-06 09:00 PST