Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Implications of enabling security.csp.enableNavigateTo

I occasionally use a site (www.zoomcare.com) which does not work properly with Firefox (I've been using Microsoft Edge (Windows 10) to access it). The problem comes when … (funda kabanzi)

I occasionally use a site (www.zoomcare.com) which does not work properly with Firefox (I've been using Microsoft Edge (Windows 10) to access it). The problem comes when I try to login. I enter my username and password, and that brings up a blank page that does not redirect to anything, so I'm stuck.

Just out of curiousity, I was looking through Advanced Settings, and found security.csp.enableNavigateTo. It has been set to false, but when I set it to true, I am able to successfully login (I still go to the blank page, but after a brief pause, I'm redirected to a logged-in page).

I'd like to know something about the security implications of enabling this property. Is it a bad idea? (Not knowing, I've set it back to false and will continue to use Edge for now).

Asked by glchapman.misc 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

PDF download link has disappeared from banking website - Firefox only

Firefox 117.0.1 (64 bit) Build 20230912013654 Windows 10 Home - Version 22H2 OS build 19045.3448 The link to download my Sears credit card statement in pdf form has disap… (funda kabanzi)

Firefox 117.0.1 (64 bit) Build 20230912013654 Windows 10 Home - Version 22H2 OS build 19045.3448 The link to download my Sears credit card statement in pdf form has disappeared when accessing the website (https://citiretailservices.citibankonline.com) with Firefox. It still appears and works normally when the website is accessed with Chrome. I have the uBlock Origin extension installed on Firefox, but it is disabled on the Sears website. Screencaps attached.

Asked by jimcarter1 8 izinyanga ezidlule

Answered by cor-el 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Prevent Firefox from starting automatically

I have followed the steps in the "Prevent Firefox from starting automatically" article: https://support.mozilla.org/en-US/kb/firefox-starts-automatically-when-i-restart-w… (funda kabanzi)

I have followed the steps in the "Prevent Firefox from starting automatically" article: https://support.mozilla.org/en-US/kb/firefox-starts-automatically-when-i-restart-window

But Firefox keeps starting automatically when I restart my computer. Attached is an image of how the settings are now.

What should I do? This is a bit annoying. I don't use Firefox as my main browser but I work as a customer success manager for an online platform and always need to do some tests on Firefox, but I don't want it to start automatically when I turn on my computer.

I'll for instructions.

Thank you

Asked by Monique Lonardi 8 izinyanga ezidlule

Answered by cor-el 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox freezes for approx 45 seconds when using Google search (google.co.uk)

Firefox 117.0 Windows 10 When using Google search the screen locks and the cpu goes high. After approx 45 seconds the results are displayed. This does not happen using D… (funda kabanzi)

Firefox 117.0 Windows 10

When using Google search the screen locks and the cpu goes high. After approx 45 seconds the results are displayed. This does not happen using DuckDuckGo as the search engine. Google search is fine in Pale Moon and Edge. I have attached screen prints of the Firefox screen (the connection circle is constantly rotating during the 45 seconds) and a screen shot of Task Manager. This has only started happening since updating to 117 yesterday.

Thank you

Peter

Asked by YeOldeBowler 8 izinyanga ezidlule

Answered by YeOldeBowler 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

web page freeze when using search function

When hit enter key to search with google or some other website that tab just freeze for few second, can't click on anything on that website after that it back to normal l… (funda kabanzi)

When hit enter key to search with google or some other website that tab just freeze for few second, can't click on anything on that website after that it back to normal like how it work without the freeze

I already try everything i could like disable Firefox Accessibility Service, troubleshooting.

Asked by flus 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Disappearing "New Tab" button when tabs exceed width of display space

Past experience. With just a few tabs open there was a "+" button at the right hand end of the tab bar for a new tab. When the number of tabs got too many (in my case 1… (funda kabanzi)

Past experience. With just a few tabs open there was a "+" button at the right hand end of the tab bar for a new tab. When the number of tabs got too many (in my case 18) the "+" button was JOINED by a ">" button to be able to see tabs off the right hand end of the toolbar, but still use the new tab button.

Post update to the current version of Firefox, at the point the ">" button appears it is REPLACING the "+" button.

I know there are workarounds, but my "rut" is to use the "+" to get a new tab.

Is there any way of getting it back?

Asked by mara1618 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Google maps 'corruption'

Any ideas why I am seeing these strange rectangles on Google maps? Confirmed not caused by an extension as I still see them in Private window and do not see them when u… (funda kabanzi)

Any ideas why I am seeing these strange rectangles on Google maps?

Confirmed not caused by an extension as I still see them in Private window and do not see them when using Brave.

They don't stay in the same geographical location when zooming in and out.

Asked by eddielenton 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox (Flatpak) displaying text in PDF files incorrectly

When i go to open a PDF file with Firefox, the text renders incorrectly (see image) for most PDF files, but not all (i'm not sure why. And this only happens with the Flat… (funda kabanzi)

When i go to open a PDF file with Firefox, the text renders incorrectly (see image) for most PDF files, but not all (i'm not sure why. And this only happens with the Flatpak version of Firefox [1]. It doesn't happen with Firefox ESR (DEB version from my distribution) [2] and it doesn't happen if i view the same PDF file with pdf.js in a non-Firefox Flatpak app (GNOME Web) [3].

I've tried reinstalling and tried starting in troubleshoot mode, but neither seemed to fix the issue.

[1]:

  • Name: Firefox
  • Version: 117.0
  • Distribution ID: mozilla-flatpak

[2]:

  • Name: Firefox
  • Version: 102.15.0esr
  • Distribution ID: BLANK (preinstalled with Debian Linux 12)

[3]:

  • Name: GNOME Web (Flatpak)
  • Version: 44.6

Asked by Logan B 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Hanging on text box input

I'm having an issue with a particular text field. When entering any text into said text field, my CPU will shoot to 100% usage on some cores, hang for a bit and then prin… (funda kabanzi)

I'm having an issue with a particular text field. When entering any text into said text field, my CPU will shoot to 100% usage on some cores, hang for a bit and then print the text after a few seconds. I have an Intel 13900k @ 5.5ghz.

I can't provide a link to the text box as it's a WordPress CMS on my local machine. This issue does not present itself on the competitor browser.

A few troubleshooting steps I've taken:

  • Re-install Firefox
  • New profile
  • Disable all extensions
  • PC safemode + Firefox safe mode
  • Tested dev/nightly/stable (I'm using BETA daily)
  • Disabled accel

Hopefully I'm able to have an expert look at my profiler to help determine what the issue is. I'm not knowledgeable in this area unfortunately. https://share.firefox.dev/3s60ISV

Thank you.

Asked by mattskiiau 9 izinyanga ezidlule

Answered by mattskiiau 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Cursor automatically going to start of search bar infront of URL when I open a new tab

I'm having issues with the cursor when opening a new tab and I've tried a few different fixes and none are really working. When I open a new tab the cursor goes immedia… (funda kabanzi)

I'm having issues with the cursor when opening a new tab and I've tried a few different fixes and none are really working.

When I open a new tab the cursor goes immediately to the start of the homepage URL which is not helpful as if I type it just retains the URL after what I've typing(See Image). I've tried playing around with about:config to get the cursor to populate into the google search bar on the browser home screen but, it doesn't work.

I've also tried setting the new tab page to blank but, then sometimes it doesn't search google even though it says it should and says URL unrecognised(see the other images).

Why is this happening, I just want to be able to not have to manually delete the URL to search using the search bar and this seems like really basic functionality to me.

Asked by lukesummers94 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox search with Google

Using Firefox 117.0 (64 bit) with Windows 10 Pro 22H2, I have www.google.co.uk set as the home page. Whenever I use the homepage search box to enter a search term, Firef… (funda kabanzi)

Using Firefox 117.0 (64 bit) with Windows 10 Pro 22H2, I have www.google.co.uk set as the home page. Whenever I use the homepage search box to enter a search term, Firefox stalls for about 10 seconds before showing the search results. Selecting any search results opens the relevant page straightaway. Subsequent new searches using either the search box at the top of the results page or the home page again also has the 10 second delay. Using the search box in the Menu Bar does not have this delay - the results are shown straightaway. This has been happening for the past two weeks or so and using the previous version of Firefox. I've been using Firefox for many years and have never had this problem. Chrome works fine. I've tried all the "solutions" found on the internet, refreshed Firefow, tried a new profile, troubleshoot mode, etc, without any change. Also, within the past 24 hours, I can no longer open www.screwfix.com - with www.screwfix.com in the address bar, I get a completely white page without any error message. Screwfix opens fine with Chrome on this machine and with Firefox on Android tablet and phone. Please can you help with this. I'm in the UK. Thanks

Asked by stusal 8 izinyanga ezidlule

Answered by stusal 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Not able to "paste" text on Whatsapp web on Firefox Developer

Good day. Im having an issue with my Firefox developer Eidition (v 117.0b9 -64bit), where im not able to "paste" text on whatsapp web since 18th Aug 2023. (pasting imgs … (funda kabanzi)

Good day.

Im having an issue with my Firefox developer Eidition (v 117.0b9 -64bit), where im not able to "paste" text on whatsapp web since 18th Aug 2023. (pasting imgs is fine though)

Tested other ways to paste using right click / Ctrl+V but it didnt work.. and if i copy something from same whatsapp and re-apply paste, also does not work (again to remind, only pasting text does not work) !

Checking though other browsers "Edge" seems to be ok and i was able to "paste" text normally. I hv yet to check on the issue on normal Firefox Browser.

Using Windows 10. Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz 1.99 GHz RAM 32.0 GB


Since other browsers did not have this issue, i thought of raising this for Firefox devs to hv a look at it. Maybe some update done recently caused this glitch. So im doing my part in sharing feedback to improve an open source software which i use.

Thank you for the amazing browser.

Asked by Abdulaziz_10101 9 izinyanga ezidlule

Answered by Paul 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to set focus on newtab page and not the url bar

When I open a new tab, i would like the page to be in focus and not the urlbar. This is what i used to have in my mozilla.cfg: ``` // Auto focus new tab content try { C… (funda kabanzi)

When I open a new tab, i would like the page to be in focus and not the urlbar. This is what i used to have in my mozilla.cfg: ``` // Auto focus new tab content try {

 Cu.import("resource://gre/modules/Services.jsm");
 Cu.import("resource:///modules/BrowserWindowTracker.jsm");
 Services.obs.addObserver((event) => {
   window = BrowserWindowTracker.getTopWindow();
   window.gBrowser.selectedBrowser.focus();
 }, "browser-open-newtab-start");

} catch(e) { Cu.reportError(e); } ``` This worked until the last update. What solutions are there?

Asked by n6v26r 8 izinyanga ezidlule

Answered by cor-el 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Downloads has a sticky "save as" folder location for just one website.

The Backstory: As a graphic designer, I save things from the web all the time--stock websites, client downloads, all that jazz. Because I have a ton of clients, I have th… (funda kabanzi)

The Backstory: As a graphic designer, I save things from the web all the time--stock websites, client downloads, all that jazz. Because I have a ton of clients, I have the "Always Ask You Where to Save Files" option selected, and it usually does a pretty good job of remembering where I want to save stuff.

However, I've encountered a crazy bug in the last month: When I save images--jpegs specifically--from Adobe Stock, it will pop up the "where to save" window, and it will be a certain client's folder. (For clarity, we'll call this Tammy's folder.) I'll navigate to the new location I want to save assets for the current project I'm working on (let's say this is Mike's folder). Then I'll download another jpeg for Mike's folder from Adobe, but it will start me back in Tammy's folder again. This means I have to re-navigate to Mike's folder, every single time I want to save anywhere other than Tammy's folder.

Here's the weird thing: When I save .ai/vector files from Adobe stock, it remembers the last folder I saved an .ai/vector file to. Same for .pngs and other file types. On other stock websites, it will also remember, whether they are jps, zips, svgs--it works fine. It's JUST jpegs (not jpgs) from Adobe Stock.

I've tried clearing cookies, data, resetting the download location, rebooting my computer in between all the changes, and even going into the about:config to try to fix it that way. Short of uninstalling/reinstalling firefox, are there any other solutions I should try?

Thanks!

Asked by jamie50 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Shopify not working

I am trying to set up a Shopify page. It was working fine until today. The page is now redirecting me to the sign in page every time I attempt an action. Shopify support … (funda kabanzi)

I am trying to set up a Shopify page. It was working fine until today. The page is now redirecting me to the sign in page every time I attempt an action. Shopify support says that they were able to perform these actions on my account from their end. Also, I was able to complete the tasks from Microsoft Edge. Any suggestions.

Asked by mikeegan2000 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Whole desktop goes black screen sometimes starting videos

Hello! I have used Firefox on and off so I don't have a time frame of when this would have started exactly, but I have had some random completely black screens on both of… (funda kabanzi)

Hello! I have used Firefox on and off so I don't have a time frame of when this would have started exactly, but I have had some random completely black screens on both of my monitors dating back to at least 2-3 weeks ago that can only be fixed by powering down the entire PC. I've reinstalled my (NVIDIA) GPU drivers, rearranged display-port cables and just about anything before finally finding a fix, switching to edge. So far I've gone a week without black screening when with Firefox I'd get around 4 give or take a week (some days getting to 3 alone). I don't know what could cause it but I have noticed it only happens when first starting a video. Mostly YouTube but other video sites seem to have also caused it occasionally, I would just like to know what could be causing this, as I do prefer Firefox vastly and would like to switch back as soon as I can.

Will provide anything else as necessary!

Asked by Fiaking 8 izinyanga ezidlule

Answered by zeroknight 8 izinyanga ezidlule