Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Language

  • 1 baphendule
  • 1 inale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu mcalidonio

more options

I installed firefox vpn it showed luxumberg as the location. Now when I open msn.com it comes up in a foreign language. I checked firefox settings and they are set to English (US). How do I change the language so it comes up english always?

I installed firefox vpn it showed luxumberg as the location. Now when I open msn.com it comes up in a foreign language. I checked firefox settings and they are set to English (US). How do I change the language so it comes up english always?

All Replies (1)

more options

Hey there,

Thank you for reaching out through our Firefox question forum!

So we can better assist you with your Mozilla VPN questions/concerns, please contact us directly through our support channel following the link below:

We'd be looking forward to your report and helping you out!