Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps taking over default programs

  • Akukho zimpendulo
  • 1 inale nkinga
  • 16 views
more options

A while ago firefox started to take over as the program for mailto:. I even tried to stop it by changing firefox mailto to use outlook. Didn't help. I don't often use mailto, but I noticed it when I started outlook it said it wasn't the default program for everything and asked if I wanted to set it. Kept happening. Eventually I looked into default options for outlook and found mailto was set to firefox.

THEN I opened a downloaded PDF from a different browser and it opened it in firefox. I have Nuance PDF. And yes, now often when I start that it tells me that it's not the default.

And yes, I have or set the program for PDFs in FF to be Nuance PDF.

Outside of stopping using firefox, how do I get it to stop inserting itself as the default program? YES, at times I set FF to the default browser; did some recent upgrade make it mean to also set it to the default for all programs, and how can I set it to the default browser (which I do for some things I want to run at times), without stealing all the progam defaults?

WIn7Pro, FF 78.0.1 (64-bit)

Tnx,

A while ago firefox started to take over as the program for mailto:. I even tried to stop it by changing firefox mailto to use outlook. Didn't help. I don't often use mailto, but I noticed it when I started outlook it said it wasn't the default program for everything and asked if I wanted to set it. Kept happening. Eventually I looked into default options for outlook and found mailto was set to firefox. THEN I opened a downloaded PDF from a different browser and it opened it in firefox. I have Nuance PDF. And yes, now often when I start that it tells me that it's not the default. And yes, I have or set the program for PDFs in FF to be Nuance PDF. Outside of stopping using firefox, how do I get it to stop inserting itself as the default program? YES, at times I set FF to the default browser; did some recent upgrade make it mean to also set it to the default for all programs, and how can I set it to the default browser (which I do for some things I want to run at times), without stealing all the progam defaults? WIn7Pro, FF 78.0.1 (64-bit) Tnx,