搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Trying to disable animation on tab bar

  • 9 个回答
  • 6 人有此问题
  • 201 次查看
  • 最后回复者为 fabmkk

more options

I used to use Firefox 3.6, and finally upgraded to version 7.0.1.

I have like 30+ tabs open, and notice something REALLY obnoxious that my Firefox is doing. I do seem to recall 3.6 having this problem as well, but back then I was able to Google it and disable whatever value was making it do this.

Say I'm on the far left tab. I hit ctrl+t to open a new tab, or even click on a link that pops up a new tab. The tab bar does an animated scroll all the way to the right, which takes a good 2-3 seconds given how many tabs I have open... then if I close that tab, it scrolls all the way back. This scrolling is annoying and I want to disable it!!

I tried using the tab animation setting in about:config, however that only prevents it from showing the tab "grow" to fill the space. When you have tons of tabs open as I do, that's irrelevant. I believe FF3 called this "Smooth Scrolling"? How do I turn this off? I tried looking at about:config under animation, tabs, all sorts of keywords, I can't find ANYTHING relevant!

Even if I'm on the far right tab and open a new one, it makes an animation as if the new tab is "appearing" from the far right of the screen and popping into position. I can understand why some might like this but it really irks me, and I want it turned off!

被采纳的解决方案

Try to disable the pref toolkit.scrollbox.smoothScroll to false.

在上下文中阅读这个答案 👍 1

所有回复 (9)

more options

Try using

If you right click a link, and then open it, it will open adjacent to the current tab. Alternatively after changes were implemented, a suitable add-on became available

more options

Nope, that didn't do anything. The box you mentioned was already unchecked by default - and checking it didn't do anything either. I tried restarting Firefox between each.

And that addon also did nothing. I already have it set to open new tabs at the end, THAT problem is just a simple about:config value to fix which I've already done. Even with the addon, it does the odd animated scrolling effect.


And sorry about the double post, when I posted this first question, it asked me to verify my account and I couldn't find the question again so I assumed it wasn't successfully posted.

more options

Why not just right click and open as a new tab, it will open adjacent to where you are instead of 30 tabs further along.

more options

That's not my point. I WANT the tabs to open at the end, I just don't want the stupid animation. It never did this in earlier versions of Firefox, it just instantly showed the end of the row.

Now it animates it as it moves and it just takes longer.

more options

install the Stylish extension, then after restarting Firefox install the style

See if that does what you want; I think you will have to read the comments and make some configuration changes as well in about:config though some of them are now in the css code.

Sorry for the messed up before and after pictures and links that look like "[*]" at userstyles.org, which are beyond my control.

If it does more than you want you can modify it or search for other styles based on descriptive text or on parts of the actual code that you do want..

由David McRitchie于修改

more options

Hmm. That does get rid of the animation, but it also makes all my tabs stupidly tiny and disables the scroll wheel scrolling through them.

Looking through the code I can't even find anything about disabling animation, it looks like I'd literally wind up commenting out the entire thing to make it look normal.

In other words, I like the normal look, all I want to do is disable the animations.

I take it there's not just a simple about:config setting I'm not seeing?

more options

选择的解决方案

Try to disable the pref toolkit.scrollbox.smoothScroll to false.

more options

THANK YOU!

That did the trick. I figured there was some about:config value but I couldn't figure out which. Ironically it doesn't have "tab" or "animate" in it so I wasn't seeing it!

more options

OH THANK YOU SO MUCH!

I've searched for this for years ever since i switched from Tab Mix Plus to Tab Utilities. Tab Utilities rocks but it doesn't disable this option by default like Tab Mix Plus did.

Now all those 'Fears' of scrolling through hundreds of Firefox opened tabs will go away.

THANKS!