搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

firefox displays hebrew reversed (left to right) no matter what encoding i use- help?

  • 5 个回答
  • 1 人有此问题
  • 27 次查看
  • 最后回复者为 Tomer Cohen

more options

every page that is in hebrew is displayed backwards (the letters are reversed, and is written left to right)- i tried changing my text encoding options but it did not help. i searched around the internet for help but couldnt find anything, i would appreciate an answer, as i do love using hte internet with firefox, and i find myself using other browsers for hebrew pages, which is a real bummer. thanks!

所有回复 (5)

more options

Until you find the actual cause of the problem this might help, toggled on/off from the Tools menu.

Force RTL :: Add-ons for Firefox

Be sure to read through the Developer's Notes and User's Notes for the extension, you may find additional help in them.

I think it is generally the web site.

more options

thanks for your reply, dmcritchle :) unfortunately that did not work, and only changed the interface of firefox to RTL, but the text stayed the same- the problem occurs on every page where there is hebrew, and has nothing to do witht he site im on- if i will try to type hebrew in this window right now, it types it in reverse, its very strange. i would appreciate any help, its extremely frustrating!

thanks

more options

this past month i tried pretty much everything to fix this issue- including uninstalling firefox completely (removing evrything from everywhere) but still the same problem after re-install. any ideas?

thanks

more options

So something like this from the Google.co.il page appears wrongly?

תוכל לבחור את שפת החיפוש שלך

Are you using a custom theme or the default theme?

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

You can also check the bidi prefs on the about:config page to see if any have changed and show as bold.

more options

Hi, sorry for the late reply.

If you have not yet resolved your problem, I'd be happy to provide help.

Your issue sounds like character encoding issue; please make sure you are using Hebrew-Logical character encoding and NOT the visual one.