搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox and thunderbird: invisible dropdown menus / missing overlay planes

  • 14 个回答
  • 1 人有此问题
  • 22 次查看
  • 最后回复者为 Terry

more options

Hi all, due to the occurring problem I cannot select topic to describe best my type of question:

Description of fault: Using Open Suse Leap current version 15.3 (KDE) with all patches installed (zypper dup: no action required) In either thunderbird and firefox application (but e.g. not in dolphin or k3b or gimp...) I have following problem: When pressing any entry in File ... View... bar I do not get a visible dropdown menu to chose from Firefox specific: When I try to use a bookmark folder in the bookmark bar there is no visible dropdown menu to chose from When I try to chose from a dropdown menu inside the content of a web site i will get no visible feedback at all.

BUT: when I want to chose a bookmark that should appear in a dropdown list and I move the mouse to that remembered position I see in the lower left corner the bookmark's address and I can chose it! The same happens with the dropdown menus from the the File.... View... Help line. I am able to chose a command once I remember where to point to.

So I guess all what is missing is the overlay plane where the menu contents reside.

This problem occurs in 95% of the time I use both applications, BUT there are 5% of the time where everything works like a charm. I have no idea what i do differently in that usage. Whenever Firefox works normal, also thunderbird does. Is it somehow a KDE releated problem?

How can I fix that problem? Any hints?

Thank you

Johannes

Hi all, due to the occurring problem I cannot select topic to describe best my type of question: Description of fault: Using Open Suse Leap current version 15.3 (KDE) with all patches installed (zypper dup: no action required) In either thunderbird and firefox application (but e.g. not in dolphin or k3b or gimp...) I have following problem: When pressing any entry in File ... View... bar I do '''not''' get a visible dropdown menu to chose from Firefox specific: When I try to use a bookmark folder in the bookmark bar there is '''no visible dropdown menu''' to chose from When I try to chose from a dropdown menu inside the content of a web site i will get '''no visible feedback''' at all. BUT: when I want to chose a bookmark that should appear in a dropdown list and I move the mouse to that remembered position I see in the lower left corner the bookmark's address and I can chose it! The same happens with the dropdown menus from the the File.... View... Help line. I am able to chose a command once I remember where to point to. So I guess all what is missing is the overlay plane where the menu contents reside. This problem occurs in 95% of the time I use both applications, BUT there are 5% of the time where everything works like a charm. I have no idea what i do differently in that usage. Whenever Firefox works normal, also thunderbird does. Is it somehow a KDE releated problem? How can I fix that problem? Any hints? Thank you Johannes

所有回复 (14)

more options

You can check the KDE settings by right-clicking the title bar or, if you don't have the title bar, alt+f3 and select More Actions > Configure Special Window Settings OR Configure Special Application settings > Window types. In my case, all window types are ticked/checked.

You could check to see whether the problem still occurs in troubleshoot mode or try a new profile. https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

有帮助吗?

more options

Today is is just working. I do not know why, but I started the system as always logged in an started Firefox and it worked perfecet. checked above what you told me and in my german version there is no tab called window ypes (first tab contains of a section window types but there is no possibility to check or tick something, second tab Size and Position, third tab Ordering and Access, fourth tab Appearances and corrections - all of these check boxes are not checked) I try to add a picture of the first tab.

Also I want to mention that Thunderbird also works like a charm.

I will log in again and see whether it still works.....

Thank you

有帮助吗?

more options

after re- login (not reboot) firefox does not work again and checking your hint does not show any differences (nothing ticked, same first tab).

Hmmm...

What else can I do?

Thank you!

Johannes

BTW: I added a pic where you can see my browser window. see the grey "Info" Bookmark folder in the bookmark bar (I clicked on it and then moved the mouse further down as if I wanted to chose from a menu) and see in the left lower corner the website that i could chose by left mouse click. The mouse i was not able to record was positioned 25mm below the "Info" folder

有帮助吗?

more options

Hello. Perhaps the issue has nothing to do with KDE. I am attaching a screenshot of my KDE dialogue. I would try the troubleshooting and/or new profile options. EDIT: I just remembered this happens also with Thunderbird, which is why you are thinking it's a KDE issue.

由Terry于修改

有帮助吗?

more options

Hi, I have made a new firefox profile. Still the same problem.

有帮助吗?

more options

Troubleshoot mode (started from console as the menus do not work ;-) did not change behaviour of firefox so next try is to refresh firefox....

有帮助吗?

more options

refreshing firefox does not help either. still no menus.

What else can I do?

What if the problem *is* a KDE problem? Where could I start troubleshooting? Why is just firefox and thunderbird affected, no other application? Opera works normal, kmail also. What differenciates these 2 failing programs from other applications?

Thanks!

Jo

有帮助吗?

more options

Do you see any relevant-looking messages if you start Firefox via a terminal window ?

有帮助吗?

more options

unfortunately firefox does not tell anything when started from the shell

有帮助吗?

more options

You could try a different user account.

有帮助吗?

more options

I have set up a new user account using a fresh firefox account and this account has same problems

有帮助吗?

more options

Try downloading Firefox from Mozilla, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

I would also try 15.4 or Tumbleweed from a USB stick or VM to see if you have the same issue. In the Settings and then Appearance, did you make any changes? Let me boot to 15.3 to see if I have the same issue.

Operating System: openSUSE Tumbleweed 20220525 KDE Plasma Version: 5.24.5 KDE Frameworks Version: 5.94.0 Qt Version: 5.15.2 Kernel Version: 5.17.9-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600

有帮助吗?

more options

schjo said

I have set up a new user account using a fresh firefox account and this account has same problems

Under the new user account, did you log into your Firefox account and sync your data?

由jonzn4SUSE于修改

有帮助吗?

more options

jonzn4SUSE said

schjo said

I have set up a new user account using a fresh firefox account and this account has same problems

Under the new user account, did you log into your Firefox account and sync your data?

Surely that would defeat the purpose of using a separate account.

有帮助吗?

我要提问

你必须登录到你的账号才能回复。如果你还没账号,请提出一个新问题