搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Update option is checked but FF will no automatically update and keeps asking to download newer version.

  • 4 个回答
  • 2 人有此问题
  • 106 次查看
  • 最后回复者为 topocalc

more options

Using 68.0.2 in Debian 9.4 Stretch. Originally FF 68.0.2 was installed in my Downloads directory but I moved it to /opt and is still working fine. Since the release of version 69 it has been pestering me asking for an update, even that the automatic update option is checked on. Downloaded 69.0 and again moved to it to /opt. Renamed the 68.0.2 from firefox to firefox 68 and tried to run 69 but it will not respond. Any ideas on how to solve this issue? Thanks.

被采纳的解决方案

If you run a Firefox version installed in '/opt' then you won't be able to update this version as a regular user

If you install Firefox in '/opt' that you can update Firefox if you start Firefox as root via a 'sudo' command to have write permission for '/opt'.

You can find the full version of the current Firefox release (69.0.1) in all languages and all operating systems here:

在上下文中阅读这个答案 👍 0

所有回复 (4)

more options

Did you get your Firefox from Mozilla or the Linux Distro?

more options

Thanks for your interest. I got FF directly from Mozilla. My first version was 66 and automatically updated twice.

more options

选择的解决方案

If you run a Firefox version installed in '/opt' then you won't be able to update this version as a regular user

If you install Firefox in '/opt' that you can update Firefox if you start Firefox as root via a 'sudo' command to have write permission for '/opt'.

You can find the full version of the current Firefox release (69.0.1) in all languages and all operating systems here:

more options

Thanks for the tip cor-el. My purpose in moving FF to /opt was saving space in my home directory. Wrong move! Cause of all unnecessary complications. Latest version now installed in /home and works fine. The older versions in /opt were deleted.