Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

How do I stop Firefox from auto filling and/or saving my usernames and passwords?

  • 4 个回答
  • 1 人有此问题
  • 275 次查看
  • 最后回复者为 Test3

more options

I don't want to save any usernames and passwords on any websites. I also don't want any websites asking me if I want to save usernames and passwords. I simply want to setup Firefox, so that any website I visit doesn't ask me and/or remember my username even if I delete my history and/or cookies.

I accessed the "Preferences" section and clicked on "Privacy & Security". The "Autofill addresses" under the "Forms and Autofill" is unchecked. If I uncheck the box next to "Ask to save logins and passwords for websites" under "Logins and Passwords", then usernames autofill on websites that I previously visited. If I check the box next to "Ask to save logins and passwords for websites" under "Logins and Passwords", then each new website I visit that requires a username, asks me if I want to save the username or never save the username.

I don't want to save any usernames and passwords on any websites. I also don't want any websites asking me if I want to save usernames and passwords. I simply want to setup Firefox, so that any website I visit doesn't ask me and/or remember my username even if I delete my history and/or cookies. I accessed the "Preferences" section and clicked on "Privacy & Security". The "Autofill addresses" under the "Forms and Autofill" is unchecked. If I uncheck the box next to "Ask to save logins and passwords for websites" under "Logins and Passwords", then usernames autofill on websites that I previously visited. If I check the box next to "Ask to save logins and passwords for websites" under "Logins and Passwords", then each new website I visit that requires a username, asks me if I want to save the username or never save the username.

被采纳的解决方案

That remember label got changed a while back and is now named "Ask to save logins and passwords for websites". You need to remove that checkmark to disable the Password Manager.

Did you look at the third case:

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [ ] Remember search and form history
定位到答案原位置 👍 0

所有回复 (4)

more options

If there are passwords stored in the Password Manager then Firefox will show these as possible suggestions. So you first need to make sure that nothing is stored in the Password Manager.

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins"

This window has a checkbox to enable auto-fill for names and passwords and you need to make sure that this box isn't checked.

Once this is done you need to disable the Password Manager and remove the checkmark.

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Remember logins for sites"

That should be sufficient to disable the Password Manager. I think that you ready disabled "Forms and Autofill". There is another checkbox under Options/Preferences -> Privacy & Security

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [ ] Remember search and form history
more options

I do not have any websites stored in the password manager and I don't have any websites in the exceptions. My Firefox is version 67.0.4. There is no "Remember logins for sites" option to check or uncheck (please see attached screenshot). The only option similar to "Remember logins..." is an option called "Ask to save logins and passwords for websites". If I check that box, then websites will ask me if I want to save usernames and passwords anytime I visit a website. If I don't check that box, then Firefox will automatically save and auto fill my username each time I visit that website.

more options

选择的解决方案

That remember label got changed a while back and is now named "Ask to save logins and passwords for websites". You need to remove that checkmark to disable the Password Manager.

Did you look at the third case:

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [ ] Remember search and form history
more options

The "Use custom settings for history" option worked. I forgot try it when you mentioned it in your first response. Sorry about that and thank you. I really appreciate your help!