Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

outlook email links not opening in new Firefox tab

more options

Every since I upgraded to Firefox 61.0.1, links in Outlook no longer open in a new Firefox window. For Firefox, I have settings set so that Firefox does not open a new tab when I click on a link in a new tab. I changed this many versions back and never had a problem with Outlook until this latest release. I have many tabs open (many internal tabs) at a time and it is very annoying to have to go back an reopen those tabs because an Outlook link opened in that tab. How do I enable some to open a new tab and others not to open a new tab.

Firefox is a memory hog. QuickBooks is a memory hog. Excel (multiple workbooks) is a memory hog. I only have those tabs open in Firefox that I use several times a day. I am an accountant.

Every since I upgraded to Firefox 61.0.1, links in Outlook no longer open in a new Firefox window. For Firefox, I have settings set so that Firefox does not open a new tab when I click on a link in a new tab. I changed this many versions back and never had a problem with Outlook until this latest release. I have many tabs open (many internal tabs) at a time and it is very annoying to have to go back an reopen those tabs because an Outlook link opened in that tab. How do I enable some to open a new tab and others not to open a new tab. Firefox is a memory hog. QuickBooks is a memory hog. Excel (multiple workbooks) is a memory hog. I only have those tabs open in Firefox that I use several times a day. I am an accountant.

所有回复 (3)

more options

Could you describe the setting you changed? I think maybe you are referring to the following group of preferences. Check (3)(A) and (3)(C) in particular:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Check your preference values:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab <= Is this what you set to prevent new tabs?

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows)
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links coming from other programs

  • -1 = apply the setting under (A) to external links (default)
  • 1 = open external links in the last active tab replacing the current page
  • 2 = open external links in a new window
  • 3 = open external links in a new tab in the last active window <= With (A) set to 1, try this one

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does that help with the problem links?

more options

Thank you very much.

Apparently browser.link.open_newwindow.override.external was reset to -1.

I changed to 3 and everything is back to normal.

more options

Thanks for reporting back. Not sure how one of the two preferences got reset and not the other one. Strange!