搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Zoom changes to default when navigating away from the page

  • 2 个回答
  • 2 人有此问题
  • 19 次查看
  • 最后回复者为 EvgenyM

more options

Problem: Page zoom level spontaneously changes to default when I switch to another tab or follow a link to another page.

Steps to reproduce.

1. Open two tabs. 2. In the first tab go to https://softwarefoundations.cis.upenn.edu/lf-current/Basics.html 3. Press Ctrl+= three or four times to increase zoom level. 4. Switch to the second tab and back to first. Alternatively, search for the string "n:nat", click on the link "nat" and go back.

Expected behavior: zoom level is the same as before switching to the second tab. Actual behavior: zoom level is changed to default.

This happens on a minority of web pages but still quite frequently. The same behavior occurs in safe mode.

所有回复 (2)

more options

Does toggling browser.zoom.siteSpecific make a difference?

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Thanks for your reply.

Setting browser.zoom.siteSpecific = false does help: the zoom is not changed. However, I like that Firefox remembers zoom on sites I visited previously, so I wouldn't want to set this to false.

Setting browser.zoom.full = false does not help. The zoom is changed. Also, I like that the whole page is zoomed and not only text.

browser.tabs.remote.autostart = false: This was the default in my case. Setting it to true does not help, either.

Setting browser.tabs.remote.autostart.2 = false does not help. The zoom is changed.

I found another setting: browser.zoom.updateBackgroundTabs. Setting it to false seems to prevent zoom from changing. I'll see how it goes.