Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

FIrefox address bar showing history as I type when option is disabled

  • 3 àwọn èsì
  • 1 ní ìṣòro yìí
  • 9 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ ralphius

more options

I have the option in privacy preferences to only remember bookmarks, no history or open tabs as I have always done.

But since the most recent update it shows my recent history when I start typing in the address bar.

Even though I should not need to, I went to the clear history dialogue and deleted all possible options from all history and no change.

Is there a fix for this bug?

Any help appreciated.

All Replies (3)

more options

Hello there. Here's a simple fix that should help solve your problem. paste about:preferences#privacy into your Firefox browser and toggle Location Bar --> History

This will prevent your searches to refer to past visited pages.

more options

Where do the history entries appear? On the Options page, Privacy panel, you control what appears in the drop-down panel. However, Firefox has a separate feature called autofill for the text that appears in the address bar itself as you type. To turn off autofill:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch the value from true to false

Was that it?

more options

Thank you for the help, but it turns out it was just my mistake. Running new set up on laptop and they were actually bookmarked. So used to previous set up and have not migrated bookmarks yet.