Неможливо ініціалізувати компоненту безпеки цієї програми

Ця стаття розповідає про причини, що викликають появлення повідомлення "Неможливо ініціалізувати компоненту безпеки цієї програми. Скоріш за все це спричинено проблемами з файлами у каталозі вашого профілю для цієї програми. Будь ласка перевірте що цей каталог не має обмежень на читання/запис та що ваш жорсткий диск не повний чи близький до того. Рекомендується вийти з програми і розібратись з цією проблемою. Якщо ви продовжите цей сеанс, ви можете зіткнутись з некоректною поведінкою програми під час доступу до функцій безпеки.".

Докладніше про інші повідомлення про помилки, що виникають при завантаженні веб-сайтів, перегляньте статтю Помилки при завантаженні веб-сайтів.


Місце на жорсткому диску

Перевірте наявність вільного місця на вашому жорсткому диску.

  1. Відкрийте Комп'ютер
  2. Клацніть правою кнопкою миші по диску C:
  3. В контекстному меню оберіть Властивості. З'явиться віконце властивостей.
  4. Перейдіть на вкладку Загальні.
  1. Перейдіть на робочий стіл.
    • Натисніть клавішу F11
  1. Оберіть Macintosh HD.
  2. Натисніть клавіші command+I, щоб відобразити інформаційне вікно Macintosh HD.
  1. Відкрийте меню Місця, виберіть Комп’ютер.
  2. Клацніть правою клавішею по Файлова система.
  3. Виберіть Властивості. З’явиться діалог.
  4. Перейдіть на вкладку Основні.

Якщо ви бачите, що місця менше чим 1МБ, вам треба вивільнити місце.


Дозволи файлів

Перевірте дозволи файлів вашої теки профілю Firefox. Файл cert8.db не повинен бути "Лише для читання".

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Клацніть правою кнопкою миші по файлу cert8.db.
  6. В контекстному меню оберіть пункт Властивості. З'явиться віконце властивостей.
  7. Перейдіть на вкладку Загальні.
  8. Переконайтесь, що опція Лише для читання не відмічена.
  9. Натисніть кнопку OK.
  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Виділіть файл cert8.db.
  6. Натисніть клавіші command+I, щоб відобразити інформаційне вікно файлу cert8.db.
  7. Розкрийте розділ "Sharing & Permissions".
  8. Переконайтесь, що обліковий запис користувача Mac встановлений в Read & Write.
  9. Закрийте інформаційне вікно файлу cert8.db.
  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Клацніть правою кнопкою миші по файлу cert8.db.
  6. Виберіть Властивості. З’явиться діалог.
  7. Перейдіть на вкладку Права.
  8. Упевніться що право Доступ встановлене в Читання та запис.
  9. Натисніть Закрити.

Перезапустіть Firefox, проблема можливо зникне.


Пошкоджений файл

Файл cert8.db, що знаходиться в теці вашого профілю, може стати пошкодженим. Закрийте Firefox та вилучіть цей файл.

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Виділіть файл cert8.db.
  6. Натисніть command+Delete.
  7. Перезапустіть Firefox.
Файл cert8.db буде створено заново після перезапуску Firefox.

Новий профіль

Через деякий час, ваші налаштування можуть стати пошкодженими із-за змін у вашій системі чи недостатнього місця на жорсткому диску. Створіть новий профіль за допомогою менеджера профілів. Докладно про це прочитайте в статті Керування профілями. Якщо після цього проблема зникла, перемістіть свої налаштування до нового профілю. Якщо ж проблема не зникла, поверніться до свого початкового профілю.





Базується на інформації зі статті Не можливо ініціалізувати компоненту безпеки браузера (база знань Мозілазін)

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.