X
Sitenin mobil sürümüne gitmek için buraya dokunun.
Firefox'unuz eskimiş ve güvenlik riski taşıyor olabilir! Firefox'u yükseltin

Destek Forumu

align text to fit on screen

Tarih

Many times the text of a webpage extends past the edge of the screen and I have to scroll horizontally to be able to read it. I don't want to have to change the font size.

Is there a way to make the page fit the screen without changing font size?

We're using windows xp and firefox 19.0.2

Ek sistem ayrıntıları

Yüklü yan uygulamalar

  • Shockwave Flash 11.6 r602
  • PDF-XChange Viewer Netscape Gecko Plugin
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Eklentiler

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

Grafik

  • adapterDescription: Intel(R) 82945G Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2772
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-5-2005
  • driverDate2:
  • driverVersion: 6.14.10.4299
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.4926']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.4926']
  • windowLayerManagerType: Basic

Değiştirilmiş tercihler

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • extensions.lastAppVersion: 19.0.2
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364731242
  • places.history.expiration.transient_current_max_pages: 53427
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.warn_viewing_mixed: False

Diğer

  • Kullanıcı JS: Hayır
  • Erişilebilirlik: Hayır
iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Could you provide the links of the website?

_________________________________________________________________________________

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Probably not in an easy way.
If web pages display that way then that means that they have CSS code to set a fixed width of containers and the width of the page.

You would have to check that and see if you can modify the width of those containers to make them fit to the width of the Firefox window (e.g. try width: auto!important; or a lower fixed width in px).

Current Firefox versions have a lot of built-in web developer tools including an Inspector and Style editor.

Sorunun sahibi

"e.g. try width: auto!important; "

Is this a setting in "about:config"?

Sorunun sahibi

"Could you provide the links of the website? "

http://www.huffingtonpost.com

cisz tarafından tarihinde düzenlendi

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

The www.huffingtonpost.com website work for me without a horizontal scroll bar if I reduce the width of the Firefox window to 1024.

Which window size are you usind?

Did you increase the minimum font size from the default (none)?

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with text not being displayed properly.