Mozilla Destek’te Ara

Destek dolandırıcılığından kaçının. Mozilla sizden asla bir telefon numarasını aramanızı, mesaj göndermenizi veya kişisel bilgilerinizi paylaşmanızı istemez. Şüpheli durumları “Kötüye kullanım bildir” seçeneğini kullanarak bildirebilirsiniz.

Learn More

How can I access alt-menu keyboard shortcuts in fullscreen?

  • 6 yanıt
  • 2 kişi bu sorunu yaşıyor
  • 39 gösterim
  • Son yanıtı yazan: Gneiss1

more options

When Firefox is not in fullscreen mode, I can access all the functions of the menu bar by pressing the appropriate alt-letter keyboard shortcut (alt-f for file menu, alt-e for edit, etc).

This seems to be disabled in fullscreen mode. So I have to get out of fullscreen, pull down the menu, and then go back to fullscreen. How can I use keyboard shortcuts to access the menu while in fullscreen mode?

Seçilen çözüm

I'll be dipped, it worked! The menu is still not visible in fullscreen (regardless of mouse position) but the alt-menu shortcuts work. I did not add the code:

"#urlbar .textbox-input-box { font-size:12pt !important; }"

Because I'm a total noob and am having trouble editing stuff in the /.mozilla/firefox directory. But that's OK, I'm all happy now. Thanks again for your help!

BTW for any other noobs who may read this, you need to turn on Show Hidden Files to see the /.mozilla/firefox directory

Bu yanıtı konu içinde okuyun 👍 0

Tüm Yanıtlar (6)

more options

You can try to add this code to userChrome.css below the default @namespace line to make the menu bar visible in full screen mode.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#toolbar-menubar { visibility:visible!important; }
more options

There was no file called userChrome.css on my system. I found an example file and added the line:

"#toolbar-menubar { visibility:visible!important; }"

directly below the zuul gatekeeper thing (except with no quote marks). Then I stashed it in /usr/lib/firefox/chrome. No result. I rebooted and tried it again, no dice. At this point I'm going to just live with it. I appreciate your taking the time to help.

Gneiss1 tarafından tarihinde düzenlendi

more options

Did you rename the userChrome-example.css to userChrome.css?

What is the file path of the userChrome.css file?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Do you get the Menu bar if you hover the mouse to the top in full screen mode (F11) with the code in userChrome.css?

Does other code in that file work?

#urlbar .textbox-input-box { font-size:12pt !important; }
more options
Did you rename the userChrome-example.css to userChrome.css?

Yup.


What is the file path of the userChrome.css file?

/usr/lib/firefox/chrome


Do you get the Menu bar if you hover the mouse to the top in full screen mode (F11) with the code in userChrome.css?

I get the tabs and the navigation toolbar, but no menu bar.


Does other code in that file work?

Oops, didn't try that. I'll give it a whirl.


Aaaaaand this is where I confess that this is a dual boot system, and I got the userChrome-example.css from the Win7 side because there was no userChrome.css file on my system. I got it from here: /host/users/(me)/AppData/Roaming/Mozilla/Firefox/Profiles/(random alphanumeric).default/chrome

Gneiss1 tarafından tarihinde düzenlendi

more options

/usr/lib/firefox/chrome is the Firefox installation folder.
You need to place the userChrome.css file in the chrome folder in the Firefox Profile Folder, probably located in your home directory ~/.mozilla/firefox

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

Seçilen çözüm

I'll be dipped, it worked! The menu is still not visible in fullscreen (regardless of mouse position) but the alt-menu shortcuts work. I did not add the code:

"#urlbar .textbox-input-box { font-size:12pt !important; }"

Because I'm a total noob and am having trouble editing stuff in the /.mozilla/firefox directory. But that's OK, I'm all happy now. Thanks again for your help!

BTW for any other noobs who may read this, you need to turn on Show Hidden Files to see the /.mozilla/firefox directory

Gneiss1 tarafından tarihinde düzenlendi