Mozilla Destek’te Ara

Destek dolandırıcılığından kaçının. Mozilla sizden asla bir telefon numarasını aramanızı, mesaj göndermenizi veya kişisel bilgilerinizi paylaşmanızı istemez. Şüpheli durumları “Kötüye kullanım bildir” seçeneğini kullanarak bildirebilirsiniz.

Learn More

I keep getting the message: firefox not responding when I try to navigate on various web sites

  • 14 yanıt
  • 5 kişi bu sorunu yaşıyor
  • 19 gösterim
  • Son yanıtı yazan: sciencemagic

more options

For some time now when I load a web site, it takes a long time to load and then I get the message: firefox not responding, or long running script, and not responding. This happens on many web sites, and when it does, it takes very long to navigate on that web site. I also have this problem on other browsers. Any suggestions as to what might help? Thank you.

For some time now when I load a web site, it takes a long time to load and then I get the message: firefox not responding, or long running script, and not responding. This happens on many web sites, and when it does, it takes very long to navigate on that web site. I also have this problem on other browsers. Any suggestions as to what might help? Thank you.

Seçilen çözüm

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu, choose History, and then "Clear Recent History...".
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Bu yanıtı konu içinde okuyun 👍 4

Tüm Yanıtlar (14)

more options

Seçilen çözüm

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu, choose History, and then "Clear Recent History...".
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Thanks ruwaiz for your reply. I will try your suggestions and get back with you if they solve my problem. Again, thanks.

more options

Hi, since this is happening on other browsers, it may be that something else is running on your machine and hogging the CPU and RAM - have a look in the Task Manager (Ctrl + Shift + Esc) > Performance and Applications tabs. Also watch out for Windows or other updates taking place, which can slow things down as well, especially if you have limited memory.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Scribe_uk,

   I haven't looked there. Being I'm not a computer wizard, what am I suppose to look for when I access the task manger? When I did, I saw my 1 thing with applications, it was my question for firefox regarding this issue, I saw nothing else within applications. In so far as performance, I did see a lot of "stuff" but I really don't know what to look for, Scribe_uk. What should I be looking for when I click on the performance tab? Thanks for your input.

sciencemagic tarafından tarihinde düzenlendi

more options

cor-el,

  When I tried your suggestions cor-el, •Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available, to try and delete hardware acceleration, in the advanced tab I didn't see a box pertaining to hardware acceleration within that advanced tab, cor-el? How do I access disabling or enabling hardware acceleration? Going to •Tools > Options > Advanced > General > Browsing: I couldn't find it? Any suggestions? Again, thank you.
more options

Hi sciencemagic, when you reply, if you could avoid starting new paragraphs with spaces, they will lay out better. This is a quirk of this site, sorry.


When you are viewing Options, in the Advanced panel, there are little mini-tabs (General, Data Choices, Network, etc.). The hardware acceleration checkbox is in the General tab.


Also, unresponsive script issues can be caused by the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting to turn it off:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

If you have been using Flash recently, the change will be delayed until all Flash has been unloaded for a few minutes, or you close Firefox and start it up again.

more options

sciencemagic said

Scribe_uk, I haven't looked there. Being I'm not a computer wizard, what am I suppose to look for when I access the task manger? When I did, I saw my 1 thing with applications, it was my question for firefox regarding this issue, I saw nothing else within applications. In so far as performance, I did see a lot of "stuff" but I really don't know what to look for, Scribe_uk. What should I be looking for when I click on the performance tab? Thanks for your input.

Hi again, just seeing Firefox in Applications is good news, and means that nothing else is running.

In the Performance tab, the CPU Usage should be very low - just a few %, although it will probably be fluctuating a bit. The Memory - which is your RAM usage, should be below about half-way up, although depending on the amount of RAM on your PC it may be much lower. In essence, if it's very near to maximum, there may not be enough for Firefox to run smoothly.

Incidentally, If you close Firefox the Memory will drop, but it shouldn't be dramatic!

more options

jscher2000. Thank you for your reply. I did as you instructed to disable acceleration hardware. Are you too advocating that I disable it? Secondly, your suggestion about unresponsive script issues and how flash player plugin can have an influence, are you advocating I try disabling the protected mode in your opinion? Or is fiddling with flash player plugin something like that a last resort? I say that because I got the impression you may have some reservations about running flash player in unprotected mode? If not, I will give it a try. I appreciate your help, jscher2000.

more options

Scribe_uk. Thank you for your reply. Yes, my CPU usage is very low as you thought, about 6% an average. And, my memory is about 1/3 up the scale, also about right it seems. I presume when I visit the task manager and look under applications I should see only 1 or 2 sites being used or visited? Not sure what I should be seeing when I view the application tab in task manager. But, nonetheless it should be very few sites being displayed? Again, thank you for your help, it is appreciated.

more options

Hi sciencemagic, it's always preferable to use the more advanced features if you can, but sometimes there are bugs, and in that case, it is preferable not to have your computer drive you crazy.

You can help manage your risk of bad flash media by setting the Shockwave Flash plugin to "Ask to Activate". That way, you get to decide whether random websites you visit can run Flash.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

If you don't need to change the setting, you can just ignore the notification and enjoy the non-Flash content.

more options

Thanks again for your reply, jscher2000. When I look at Flash settings, they were already in ask to activate mode. So, I presume there nothing more to do regarding that. What I found interesting when I viewed my plugins, there were 2 Shockwave Flash plugins versions. One was 11.9 and was in red saying I need to update it, or problems could happen. The other Flash plugin was 17.0 version. I sort of presume I already have the newest version and I can ignore the warning to update the old version? If so, why is the older version even shown in my plugin lists? It just makes things more confusing. Thanks, jscher2000.

more options

Regarding multiple version of Shockwave Flash, sometimes Adobe's updater is not able to remove the old version when installing the new one. Although the cleanest approach is to remove ALL Flash from the system using Adobe's uninstaller, because this also cleans stray Registry entries, you could delete the old plugin file manually as a quick fix if you like.

more options

ruwaiz razak. It's been awhile now and the problem hasn't come up yet again. So, it appears your suggestion, for now at least, has solved my problem. Thank you. I also used some of the other contributors help and it their help may have helped also. Again, thank you all!