Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I enable reader view on Firefox quantum in Linux, CTRL + ALT + R also not working

  • 6 ప్రత్యుత్తరాలు
  • 7 ఈ సమస్యలు కలిగి ఉన్నాయి
  • 77 వీక్షణలు
  • చివరి సమాధానమిచ్చినది Jan-holtman

more options

How can I make firefox enter reader view on Linux. Also CTRL + ALT + R is not working. Before quantum it was working with the active reader view extension

How can I make firefox enter reader view on Linux. Also CTRL + ALT + R is not working. Before quantum it was working with the active reader view extension

ఎంపిక చేసిన పరిష్కారం

Hmmm, that's odd. To be clear, I don't have any reason to believe this is going to be fixed in 58 - rather, the Addon I mentioned above that adds a permanent reader button to your toolbar would require at least 58 to work, but it sounds like you're having a different issue where the built-in button never appears.

If you open about:config and search for "reader.parse-on-load.enabled", is that setting set to false?

ఈ సందర్భంలో ఈ సమాధానం చదవండి 👍 2

ప్రత్యుత్తరాలన్నీ (6)

more options

It looks like the activate reader view extension (https://addons.mozilla.org/en-US/firefox/addon/activate-reader-view/) works with Firefox 58, which means that it will work again in a few weeks when the next version of Firefox is released.

In the meantime, you could download the beta version of Firefox, or alternatively you can open pages in reader view without the extension by typing "about:reader?url=" followed by the page you want to read into the address bar.

more options

Indeed reloading the website with and adding the "about:reader?url=" does enter the reader mode for the website, but this means that I have to always do it manually always. Yes it does help, but there must be another way to enable Firefox to enter reader mode. It show however that Firefox is able to do it. But how can I get the button back so I don't have to do it manually?

more options

Are you saying that the button never shows up, or that it only shows up sometimes (and you want it to show up all the time)?

The default behavior is for the button to show up only when the reader mode detects an article it can format. if you're not seeing that (try this URL, for example: https://en.wikipedia.org/wiki/Firefox ), let me know.

If you want a permanent button that always appears, even when the page isn't detected as an article, you'll need to use the extension mentioned above, meaning you'll need the beta version of Firefox.

more options

The button never shows up for some reason on one of my computers. But when I add "about:reader?url=" in front of the URL of the website then it works. Also then I can switch the reader view on and off with CTRL + ALT + R. The button never shows up however. But if the problem is solved with Firefox 58 in a few weeks time then I will probably have to wait for Firefox 58

On two of my computers i am running Linux LXLE and on both of these computers reader view does not work anymore. On another machine running Xubuntu reader view works.

On the Windows machine reader view also works.

more options

ఎంపిక చేసిన పరిష్కారం

Hmmm, that's odd. To be clear, I don't have any reason to believe this is going to be fixed in 58 - rather, the Addon I mentioned above that adds a permanent reader button to your toolbar would require at least 58 to work, but it sounds like you're having a different issue where the built-in button never appears.

If you open about:config and search for "reader.parse-on-load.enabled", is that setting set to false?

more options

Thank you, that was it, the reader.parse-on-load.enabled was set to false. I toggled the setting and now it works. Thank you