Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos on YouTube have sound, but there is no picture. Any suggestions? I just updated Firefox a few miutes before the problem started occurring.

  • 10 பதிலளிப்புகள்
  • 92 இந்த பிரச்னைகள் உள்ளது
  • Last reply by fangflyer

I watch videos on Youtube, and shortly after updating Firefox, I have noticed that the sound for the video is fine, but the image is a blank screen. I have looked at every control and I can find no reason why I get sound but no picture when playing the video.

All Replies (10)

Clear the cache and the cookies from sites that cause problems.

  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites causing problems: Tools > Options > Privacy > Cookies: "Show Cookies"


Thanks, it worked! Out of curiosity, where on this planet are you located? I'm in America.

Best regards,



The fix worked initially, but now it holds for one video, and then on the next selection, the sound is perfect, but the video is blank. If I stop, and follow your procedure, I am able to watch the video, but the with the next selection, the picture is gone again.... Ideas?


IMO, revert to the previous Shockwave Flash 10.1 r102 version. I feel the current Shockwave Flash 10.2 r152 version is causing most of these problems. Adobe is blaming Firefox 3.6.14 & 3.6.15, but I have seem postings in other forums that Firefox 3.6.13 users are having problems with the new version of Flash, too.

I haven't updated from Shockwave Flash 10.1 r102 and have had none of the problems that users are reporting here - with 3.6.14 for a few days and since Friday when 3.6.15 was released.

Just my opinion. I have the new version of Flash sitting in my downloads folder, just didn't get around to installing it last week - now I am glad I waited. I am waiting on Adobe coming up with a "fixed" version before I "update it".

the-edmeister மூலமாக திருத்தப்பட்டது

The cookies issue only works ONCE. After that you either need to disable the cookies for that site or clear them again.

If you disable them, you can't log in to your own channel on youtube.

From "Trill" on Youtube help forum. Worked for me.

ANSWER--- I managed to get this worked out. My videos are now coming through fine. You must go to a web page that has a you tube video posted on it. Then right click, then click on settings. This will bring up a panel in flash player which will have Hardware Accelerator checked. Uncheck it and that should resolve the problem

PLEASE, don't tell us to disable hardware acceleration any more!

We've heard that work-around and it's not acceptable to anyone who doesn't want all flash pages moving at a snail's pace.

You have to clear cache and reload the video every single time.

I have the same problem on Internet Explorer !!! Both FireFox and IE, both sound no picture. I can clear the cache and reload the youtube video with no picture only sound and after these 2 steps I can get the video to play every time either browser but only fixes one video at a time.

Then after I click on a new vid it's the same problem all over, clear cache and reload the video and it plays. Doesn't matter for me which browser I use, IE or FireFox. Annoying. Started after I installed the new update for Flash.

I haven't figured out what's causing it but it's definitely related to my cache since this fixes it every time for only 1 video at a time. But it's affecting both my web browsers IE and FireFox so I don't think it's a browser issue.

I found a better solution. Click the popout window on each youtube video that does not show the picture to lauch the video in to a separate window. It plays fine.

Link to source.

Thanks for all your suggestions. I had solved the problem by reloading an earlier version of Adobe, but today, I was alerted that a "new update"was available. I downloaded it, and the problem reappeared! I went and reloaded the earlier version, and now it works fine!