Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox downloads two copies of everything

  • 7 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • Last reply by autolycus1

Please stop duplicating all my downloads into the default folder as well as the location where i ask it to

Please stop duplicating all my downloads into the default folder as well as the location where i ask it to

All Replies (7)

autolycus1 said

Please stop duplicating all my downloads into the default folder as well as the location where i ask it to

I thought i was filling in a request form

Very little background information for anyone to know where the downloads are or how they are downloading to know what's happening.

Thanks for the response. I hope the thumbs down wasn't from me, maybe the link i followed to get back here?

Every time i download a file, FF asks me where i want to save it. Wherever i choose, it also downloads a copy to my default download folder that i have chosen in settings. That's about it - but happy to provide more info if you need it.

autolycus1 மூலமாக திருத்தப்பட்டது

You need to provide the url your downloading from so others can verify the issue and if login another site not requiring this so others can test what is happening.

Firefox probably started downloading the file in the background before you specified the folder, with the plan to move it once the download completed. Move probably is actually copy then delete, so perhaps the delete part is failing?

I don't know whether it will make any difference, but:

You may remember that before Firefox 98, Firefox did this initial background download into the Windows Temp folder. You can switch Firefox back to the Temp folder and see whether that helps. Note that this means if you "open" a PDF or other file, it will not be saved to your "Save files to:" folder and you'll need to save it manually if you want to keep it. Here are the details:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste and pause while the list is filtered (note: Firefox 102 and later)

(3) Double-click the preference to switch the value from false to true

It is possible that (anti-virus) security software is causing the problem. Try to disable security software temporarily to see if that makes a difference.

Thanks for the replies.

Actually, it seems that the problem occurs when i chose the FF option to open the file in Foxit and then decide to save it in Foxit. That's when I get an extra unwanted copy in my FF default download folder.

If i chose the FF option to save the file, i get a xxxxpdf.part file that appears in my default download folder and then disappears after the download to my chosen folder is complete. So i guess i can get round the problem by always choosing the download option and then opening the file in Foxit. It's a bit of a pain though.