Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Internet connection

  • 17 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 50 views
  • Last reply by FredMcD

  • I start Firefox. It works fine for a time
  • Then, out of the blue, it says I have no Internet connection
  • But, every other browser works just fine
  • If I restart Firefox, it again works just fine, until it doesn't, again
  • It just started doing this a few days ago
  • I know everyone says this, but I didn't change anything other than the automatic update Firefox performed

Does anyone have a solution to this problem? Thanks.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Well, McD, I hope it's OK to call you that. It sounds like a superhero's name. Anyway, it must have been a Firefox bug because after last night's update (v96.0.3), or maybe two nights ago, Firefox has been running continuously without once giving me that disconnection error.

Thank you for all your help. It is much appreciated.

Read this answer in context 👍 0

All Replies (17)

About how long before the problem starts?

What about other programs? Any issues using them?


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

It will take a while to run these tests because it takes a good while before it tells me I have no connection. The time between start and error seems to vary, but it's not just a few minutes.

Helpful?

I should have added; have your ISP check your service. And, when you lost the connection, try using another program that uses the web.

Helpful?

Again, this only started a few days ago. It seemed to coincide with the update to v96.0.2, but I'm not certain of that. Also, I'm running the same programs I always run and Firefox is the only one with this problem. No other browser drops the Internet connection.

Helpful?

Is it possible this is a bug in Firefox.

Helpful?

It is possible. That is why we try different things first. If we can't resolve it, then the next step is a bug report.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Well, McD, I hope it's OK to call you that. It sounds like a superhero's name. Anyway, it must have been a Firefox bug because after last night's update (v96.0.3), or maybe two nights ago, Firefox has been running continuously without once giving me that disconnection error.

Thank you for all your help. It is much appreciated.

Helpful?

Glad to help. Safe Surfing.

Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Helpful?

I don't see a 'Solved' button next to my last post, but it looks as if your last post is the 'Chosen Solution'. Is there a way to change that?

Helpful?

Looks like it has been done.

Helpful?

But, I think it was done incorrectly. Instead of flagging MY last post, I think I inadvertently flagged YOUR last post. Is there a way to fix that?

Helpful?

Go to that message, and use the Undo link to its right.

Helpful?

Got it, now. I don't know how I missed those two buttons at the bottom right. It was like they were in a blind spot. Thanks for your help.

Helpful?

I figured out what the problem was. My dark mode add-on had a "hiccup". I switched it to a different setting, then went back to what it was set to, and those buttons on the bottom right became visible. Thanks again.

Helpful?

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

If you could, please send a message to that theme's support/uploader on this.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.