Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

High CPU load due to certutil.exe

  • 7 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 1 view
  • Last reply by Soushi

Hello, this seems really weird, but here's my problem: after opening Firefox it starts spamming certutil.exe proceses and loads my CPU to 90%-100% pretty much immideately. It doesn't mater how many tabs are open or what's loaded on them - even opening up single about:preferences tab leads to this behavior. I tried pretty much everything: manualy updating to the latest version, running Firefox in safe mode, completely uninstalling Firefox and deleting all mozilla-related folders in AppData, starting it under new "clean" user profile, rolling back to version 60.0. Nothing seems to work. Any suggestions?

Windows 7 Pro x64 Firefox 61.0.2

Soushi மூலமாக திருத்தப்பட்டது

All Replies (7)

hi, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum (or if it's too long through a site like and provide the link here)?

this might give us a clue what is going on. thank you!

Yes, it's quite long, here's pastebin link:

Tried installing version 60.0 in the meantime, same result.

thanks, so for a start i would go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser - this prevents some 3rd party tools from messing with firefox through an api that wasn't intended for that.

i don't think that plain firefox would somehow interface with certutil.exe, so you might also look into programs on your system that might somehow influence or change behaviour of the browser (security suites, password managers, etc.).

finally, some sites also indicate that high cpu use in certutil.exe might be a symptom of malicious activity, sonext to the security software already in place, please run a scan with various other security tools like the free version of malwarebytes, adwcleaner & eset online one-time scanner.

Note that certutil is a tool that can be used to add certificates to the Firefox Certificate Manager, but you should never make changes to files in the profile folder while Firefox is running. It is likely, like posted above, that other software is interfering with Firefox. This can be security software or malware.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

Disabling accessibility services didn't help, running complete malware scan atm and will have some results tomorrow (lots of files on that PC).

After that I'll check if booting Windows in safe mode will change anything.

Soushi மூலமாக திருத்தப்பட்டது

A little update on the situation: virus scan didn't uncover any active malware on my PC; when booting windows in safe mode the problem did not present itself, firefox runs and displays web pages normally, without any issues.

I also tested this on two other PCs on the network: Windows 7 one had exactly the same problem as my own PC, while on Windows 10 it worked correctly.

I'm guessing someone changed something in Group Policies, related to Win7 certificates, and it broke Firefox somehow. I'll try to find out exactly what was going on.

Soushi மூலமாக திருத்தப்பட்டது

Okay, so I've found what the problem is, only thing left is to fix it.

By running Process Explorer I see the following behavior: Firefox tries to add some certificates to it's database by calling certutil with arguments:

"C:\Program Files (x86)\SearchInformAgent\sifiltersvc1\nss\certutil" -A -t "TCu" -i "C:\Program Files (x86)\SearchInformAgent\sifiltersvc1\Generic Root CA 3.cer" -n "Generic Root CA 3" -d sql:"c:\users\evzhadan\ff"-f pwfile

The problem is that the last key is missing the space prior to "-f" key at the end and certutil throws PATH NOT FOUND error with path = "C:\users\evzhadan\ff-f\cert9.db" constantly.

Soushi மூலமாக திருத்தப்பட்டது