Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox cannot connect to any website; states "Performing a TLS handshake to ..." and hangs at this point.

  • 4 பதிலளிப்புகள்
  • 20 இந்த பிரச்னைகள் உள்ளது
  • 138 views
  • Last reply by Keynes66

Suddenly, Firefox cannot connect to any website. It starts normally, but when a URL is entered, the lower left states "Performing a TLS handshake to www.xxx.xxx" where xxx.xxx is the requested website. I refreshed Firefox, and I also started Firefox with Add-Ons Disabled, but the same problem always occurs. I tried turning off antivirus software, and also tried turning off Windows Firewall. None of these solved the problem. Running Windows 10 and latest Firefox (54.0.1 32-bit). Please help.

All Replies (4)

I have this problem with one site only on my Mac. StockCharts.com. No similar problems on any other websites. StockCharts told me no one else had reported this problem. I CAN log onto Stockcharts via Safari. As the original question had it...this only started happening about two versions of Firefox back. Am not a technical person and hope there's a simple (VERY simple) solution. Thank you.

Hi Keynes66

Try to disable IPv6 (check for other possible causes as well).

BINGO! That did it. Thank you very much.