X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Missing option to show blocked popup in yellow notification bar

Posted

I have popups blocked by default. But banks etc. occasionally like to show important info in popup windows. Bank web sites usually give you one chance so adding a site exception is little help

I use FF v18. When a popup is blocked I see the yellow notification bar across the top of the screen. If I click the bar I see a few options, like add the site to the exception list. I do NOT see the option that was once there several versions ago, an option that showed the URL of the popup. If that option was clicked it opened the popup.

This was a lifesaver!! How do I get it back??

This Mozilla help document talks about the show popup option that I want to see in the yellow notification bar. But the doc is odd about this one issue, the option text is shown in parentheses only and no text mentions it:

   https://support.mozilla.org/en-US/kb/pop-blocker-settings-exceptions-troubleshooting

This same question was asked recently but nobody gave a solid answer:

https://support.mozilla.org/en-US/questions/931004

My FF has this setting

privacy.popups.usecustom = true

Not documented here:

   http://kb.mozillazine.org/About:config_entries

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Google Update
  • Picasa plugin
  • Garmin Communicator Plug-In 4.0.1.0
  • Shockwave Flash 11.0 r1
  • Foxit Reader Plug-In For Firefox and Netscape
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Gingerbread Man
  • Top 25 Contributor
219 solutions 899 answers

Helpful Reply

ChrisLott wrote:

Bank web sites usually give you one chance so adding a site exception is little help

What do you mean? If you add an exception for a site, then no pop-ups from that site are blocked. You don't need the information bar to add an exception: you can add exceptions in the Options window, Content panel. See the Pop-up Settings section of the article you linked to:

ChrisLott wrote:

I do NOT see the option that was once there several versions ago, an option that showed the URL of the popup.

It might be a site-specific issue.

1. Can you see the pop-up window when clicking the Open Window button on the following page? It should open normally, with no information bar displayed.

2. The following page should trigger the information bar. Can you see the menu items with the blocked pop-up window URLs?

ChrisLott wrote:

But the doc is odd about this one issue, the option text is shown in parentheses only and no text mentions it:

The menu item says something like, Show ‘http://www.example.com/pop-up.html’. The support article can't mention a specific URL, since it differs for each user.

ChrisLott wrote:

privacy.popups.usecustom = true

That's the default value. As you can see from the article you linked to, that preference apparently has no effect.

Modified by Gingerbread Man

Question owner

Thanks very much for the quick reply and especially for the test links.

Re bank sites and desirable popups - I mean that I've visited sites without realizing they needed popups enabled, so didn't know to add an exception. And when the yellow notification bar appeared, the option about opening a popup was absent.

Re test link 1 at w3schools - FF loads a three-pane window. On the right side is a button "Open". If I click that button, FF opens a new tab showing the w3schools' home page. This is not what I call a popup, for what that's worth. I guess this confirms that javascript is enabled and working in my browser?

Re test link 2 at popuptest - FF loads the page but does not open any popup windows. It *does* show the notification bar "Firefox prevented this site ...", and when I click the "Options" button that appears there I *do* see options "Show (url 1)", "Show (url 2)" and "Show (url 3)" . This is the feature that I was searching for!!

So clearly that feature is still in FF and working. Thanks for setting me straight.

You seem to be guessing that the root cause of my complaint is a site-specific behavior. Now I realize I didn't save the URL of the credit card site where I missed a critical popup. Would this mean that on some sites that show a popup, the FF notification-bar "Options" button fails to show the url and the option to open the pop up?

Question owner

Would like to report a very recent experience with FF and popups that maybe you can try also. After posting the reply above I was reading the NY Times Sunday magazine with FF. Upon loading the magazine's page at http://www.nytimes.com/magazine/ FF showed the yellow information bar across the top of the screen "Firefox prevented this site from opening a pop-up window". Now that I'm sensitized to the issue :) I clicked the Options button, but this time only three options are there: Allow pop-ups for www.nytimes.com, Edit pop-up blocker options..., and Don't show this message when pop-ups are blocked.

Notably absent is that last option, "Show (url...)". So you suggest this is a site-specific behavior? If FF managed to notice that some bit of code (javascript?) wants to open a window and blocks it, why can't it keep the URL of the window it's trying to open?

Gingerbread Man
  • Top 25 Contributor
219 solutions 899 answers

I don't get any pop-ups on http://www.nytimes.com/magazine/. It's likely they're generated by ads, in which case they could be random, or based on the user's IP address. In short, I could reload that page multiple times and never get the exact same thing you do. Maybe someone else on this forum can reproduce the issue.

ChrisLott wrote:

So you suggest this is a site-specific behavior? If FF managed to notice that some bit of code (javascript?) wants to open a window and blocks it, why can't it keep the URL of the window it's trying to open? 

Since it works for some sites, but not others, that seems to be the case. But since I've never seen the fourth option missing myself, I can't say what might be causing it. Again, maybe someone else can reproduce the problem, and if so, dig through the site code to find out what might be triggering it.

ChrisLott wrote:

I mean that I've visited sites without realizing they needed popups enabled, so didn't know to add an exception. And when the yellow notification bar appeared, the option about opening a popup was absent.

If the information bar doesn't show up, then no pop-ups are blocked. Users can also hide it, in which case blocked pop-up notifications will appear solely as an icon on the right side of the address bar. But the latter is not your case.

If it does show up, then you can click the Options button on it, choose “Allow pop-ups for www.example.com”, then reload the page either by clicking the button to the right of the address bar, or by pressing the F5 key. Any pop-ups that were blocked before can then be opened normally.

You're welcome.

Werner Loureiro 0 solutions 5 answers

It's really an anoying bug...

It ALWAYS happened here with me.... in MANY versions of Firefox... I can't understand how Gingerbread_Man never saw this...

He surely doesn't use "Popup Blocker" option enabled, or simply doesn't use firefox too much, at all....

It's a bug that is anoying me for LONG, LONG time... in every version of Firefox, (in Windows, in Linux)...

it must be fixed!

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96644 answers

Helpful Reply

You see a pop-up block icon on the location bar that allows to make changes.

If you click that icon then the drop down list has a checkbox "Don't show info bar when pop-ups are blocked"

You can look at this pref on the about:config page and reset them via the right-click context menu:

Werner Loureiro 0 solutions 5 answers

cor-el, that doesn't solve the problem... like ChrisLott mention, the issue is:

"I do NOT see the option that was once there several versions ago, an option that showed the URL of the popup. If that option was clicked it opened the popup. "

(we don't want to block/unblock an specific website "FOREVER"... we just want to be able to "open" the goddamn blocked-popup whenever we want...)

(but some"MANY" times, this option doesn't show up...)

Werner Loureiro 0 solutions 5 answers

sorry for being rude.. I'm not sleeping well here...

just to rectify, here's the bug: http://img69.imageshack.us/img69/7254/n1rp.png

Chris 0 solutions 1 answers

Thank you. Cor-el's solution is exactly the right solution to the problem of using only the native Firefox popup blocker and having accidentally clicked the option to not show options if popups are blocked. It appears that about:config is the only way that this particular problem even can be solved, since Tools|Options|Content has only the ability to block or not block (and make exceptions for specific sites).

Modified by Chris