Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

I can't get YouTube TV (youtube.com/leanback) to play videos when I've connected through the Android YouTube app, and remotely activated a video.

  • 5 odpovedí
  • 60 má tento problém
  • 10 zobrazení
  • Posledná odpoveď od richardberger

more options

Connecting via the device and getting it activated is no problem at all. The problem is, that Firefox for some funny reason won't play the videos I select from the device. But apparently the browser reacts to it, since it changes over to that video - just without playing it. After that it'll be stuck in limbo, and I can't use YouTube TV in the browser, unless I remove all cookies for YouTube.

Connecting via the device and getting it activated is no problem at all. The problem is, that Firefox for some funny reason won't play the videos I select from the device. But apparently the browser reacts to it, since it changes over to that video - just without playing it. After that it'll be stuck in limbo, and I can't use YouTube TV in the browser, unless I remove all cookies for YouTube.

Všetky odpovede (5)

more options

Hi pedram_y,

This is interesting that the Youtube tv is not very pretty on the browser android. It will work on the mobile version og the site and automatically will open it in the Youtube app for me. If I requested youtube.com/tv again it takes me to that desktop looking page.

So, please check the preferences for how you play youtube videos. Go to about:config page and search for youtube. There are two that will pop up: general.useragent.override... this is overriding the android and tablet, but I am not sure what they do and the network handler... these are just warnings to use the external app.

Is there something in your default settings that is not opening the video in the youtube app?

more options

Hi guigs,

Thank you for the fast response.

Although I'm not sure if I completely understand your answer. Where is it you want me to check my preferences for how I play youtube videos? On my android or my desktop computer?

Just to make sure that we completely understand each other, I'll try to rephrase and explain the problem more in-depth:

I want to use the YouTube app, for the latest version of Android on my HTC One, to search for videos, and then remotely activate them so they play in my Firefox browser on my Windows 7 desktop computer (like I do on my TV/Playstation 3). In order to do this, I'm already on youtube.com/tv on my desktop, and I've paired the desktop with my youtube app on my android phone. But then (as explained originally) I remotely activate the preferred video, and the browser on my desktop reacts and goes over to the video, but it just wont play the video (this is were the desktop youtube.com/tv webpage goes into limbo, and wont react unless I remove cookies and reload the page).

I'll be looking forward to your answer, and thank you again.

EDIT: I just figured out what you meant and went into about:config for Firefox (I didn't know you could do that at first). Nothing came up but I did find a setting called general.useragent.enable_overrides ? It's status is default.

Upravil(a) pedram_y dňa

more options

I have the same problem, using Firefox 27.0.1

You can reproduce the problem as follows:

Surf to youtube.com/tv and try to start a video by clicking on it. Background changes, but video does not start playing. It does not matter if you locally click in the browser to start any video, or trigger the play action from the youtube app.

Testing with other desktop browsers:

Internet Explorer: When accessing youtube.com/tv you are redirected youtube.com. Obviously YouTube does not want Internet Explorer users to access their TV service.

Google Chrome: It works, via local click or remote trigger.

Firefox 27 with Google Chromes User-Agent: Same behavior as with default User-Agent.

BTW: That worked already with older Versions of Firefox. With at least Firefox 27 the issue started for me.

I hope that helps to find a proper solution for Firefox users.

Upravil(a) richardberger dňa

more options

Hi pedram_y,

I get it now, apologies for the confusion. I tried to pair the device at well, but then the video said it was taking too long to load. I tried this in the beta version as well.

Wow, to troubleshoot that connection I think you need a local proxy server. Actually you have to open up the Web Console and there is an error when the tunnel is established between the two devices:

Error: Loading mixed (insecure) display content on a secure page "http://chart.apis.google.com/chart?cht=qr&chs=350x350&chl=http%3A%2F%2Fm.youtube.com%2Fpair%3FpairingCode%3D539264266"[Learn More]

https://developer.mozilla.org/en-US/d.../MixedContent

You have to enable mixed content on both devices.

In about:config search for "security.mixed_content.block_active_content" to false and the other one to true. Play with those and see if that stops blocking the connection.

Also http://blogoscoped.com/archive/2009-01-15-n31.html that add on is needed.

do you get this error as well? Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

The config you are talking about is no longer in 27 TypeError: this.children.watch is null is another error I can't figure out. The error is in the javascript module. Something is very wrong, even the youtube remmote app doesn't work.

Upravil(a) guigs dňa

more options

@guigs2 Please have a look at my post.

I also checked the console and there are no blocked connections regarding to mixed content :-\

I am accessing youtube via https.