Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Wrong Scaling with HiDPI Screen on Linux

  • 12 odpovedí
  • 0 má tento problém
  • 71 zobrazení
  • Posledná odpoveď od Federico

more options

Dear Technical Support,

I'd like to report a problem which affects the rendering of websites in Firefox with a HiDPI monitor.

I'm having issues with the text and graphics of web pages, that are often mismatched or misaligned, with text being too large compared to graphical elements. See the enclosed pictures for an example; as you can see, this happens also on your website. Also, I've noted that pages (and plugins) appear to be "shrinked" as opposed to when viewed on Chrome, where they are shown to their true size.

Setting ui.textScaleFactor=100 and tweaking with layout.css.devPixelsPerPx did not change much. I must admit that I find this behavior quite strange, since HiDPI monitors have been around for more than a decade, and especially considering that this did not impact my experience with Firefox on Windows, using the same monitor and machine.

I hope to find an effective solution to this problem and look forward to your reply. Please let me know if I can be of any help in this matter.

Best regards, Federico

Dear Technical Support, I'd like to report a problem which affects the rendering of websites in Firefox with a HiDPI monitor. I'm having issues with the text and graphics of web pages, that are often mismatched or misaligned, with text being too large compared to graphical elements. See the enclosed pictures for an example; as you can see, this happens also on your website. Also, I've noted that pages (and plugins) appear to be "shrinked" as opposed to when viewed on Chrome, where they are shown to their true size. Setting ui.textScaleFactor=100 and tweaking with layout.css.devPixelsPerPx did not change much. I must admit that I find this behavior quite strange, since HiDPI monitors have been around for more than a decade, and especially considering that this did not impact my experience with Firefox on Windows, using the same monitor and machine. I hope to find an effective solution to this problem and look forward to your reply. Please let me know if I can be of any help in this matter. Best regards, Federico
Priložené obrázky

Vybrané riešenie

I think I may have solved it. The issue was custom font sizes. I restored their values to default and now everything works as it should. Thanks for your assistance anyway!

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (12)

more options

Did you try Firefox in Troubleshoot Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search104 Here is what I see in different versions of Firefox. see screenshots


Operating System: openSUSE Tumbleweed 20240228 KDE Plasma Version: 5.27.10 KDE Frameworks Version: 5.115.0 Qt Version: 5.15.12 Kernel Version: 6.7.6-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

Upravil(a) jonzn4SUSE dňa

Pomohla vám táto odpoveď?

more options

Hi, thanks for the reply. I checked and the problem still occurs in Troubleshoot Mode. See the screenshots for reference (I added the paypal login page on both Firefox and Chrome, to show the difference).

Is there anything else I can try?

Pomohla vám táto odpoveď?

more options

Are you using full page zoom and not zoom text only?

Reset the page zoom on pages that cause problems.

  • View -> Zoom -> Reset (Ctrl+0/Command+0 (zero))

Pomohla vám táto odpoveď?

more options

Hi cor-el, I already tried various zoom settings before opening the issue, nevertheless the problem persists.

Upravil(a) Federico dňa

Pomohla vám táto odpoveď?

more options

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release What OS? What Desktop? X11 or Wayland?

Pomohla vám táto odpoveď?

more options

Hi jonzn, thanks again for your reply. Using firefox-bin works just fine. What could be the cause of my problem and what can I do to solve it?

  • OS: Linux Mint 21
  • Desktop: Cinnamon

Pomohla vám táto odpoveď?

more options

I forgot the obvious question... What is your resolution? I can go up to 3200X2160.

Upravil(a) jonzn4SUSE dňa

Pomohla vám táto odpoveď?

more options

Oh noes, my resolution is 3840x2160 :/ Isn't there anything else I can do?

Upravil(a) Federico dňa

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

I think I may have solved it. The issue was custom font sizes. I restored their values to default and now everything works as it should. Thanks for your assistance anyway!

Pomohla vám táto odpoveď?

more options

Great!!! Mark it as resolved and have a good day.

Pomohla vám táto odpoveď?

more options

Some websites use padding and margin value in 'em' units what makes them font size sensitive. It is always best to leave the minmum font size to their default value of 'none' to avoid such issues.

Pomohla vám táto odpoveď?

more options

Thank you for your assistance and have a good day you too!

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.