Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Long delays with HAProxy

  • 5 odpovedí
  • 0 má tento problém
  • 1 zobrazenie
  • Posledná odpoveď od palinst

more options

I have a Plesk (apache) server that is behind HAProxy. When I connect securely to a web site through HAProxy using Firefox, I get long delays. If I use Safari or Chrome, the pages come right up without any delay.

If I connect to the Plesk server directly without HAProxy in the middle, there are no delays.

I do not know what would cause these delays that don't occur with other browsers.

I'm on a Mac: 115.0.2 (64-bit)

I have a Plesk (apache) server that is behind HAProxy. When I connect securely to a web site through HAProxy using Firefox, I get long delays. If I use Safari or Chrome, the pages come right up without any delay. If I connect to the Plesk server directly without HAProxy in the middle, there are no delays. I do not know what would cause these delays that don't occur with other browsers. I'm on a Mac: 115.0.2 (64-bit)
Priložené obrázky

Vybrané riešenie

Figured it out. It was DNS over HTTPS which is why all other browsers worked. They all use my resolver for DNS. That setting should probably not be enabled by default. The browser shouldn't do its own thing when it comes to DNS resolution without asking first.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (5)

more options

Unfortunately with login sites unless there is another user of the same service there is no real way for anyone to verify or replicate what the issue is happening here or what the connections is checking before accepting the login.

more options

Gotcha... I will see if I can set up access for the outside world and check. Any by securely I mean HTTPS. Everything now is internal. Thank you.

Upravil(a) palinst dňa

more options

Vybrané riešenie

Figured it out. It was DNS over HTTPS which is why all other browsers worked. They all use my resolver for DNS. That setting should probably not be enabled by default. The browser shouldn't do its own thing when it comes to DNS resolution without asking first.

Upravil(a) palinst dňa

more options

You can configure a canary domain on your network to tell software you want to use your own resolver.

more options

"You can configure a canary domain on your network to tell software you want to use your own resolver."

Not "software", just Firefox, and as the link you pointed me to states, canary domains is a hack to get around another hack.

Browsers should browse. If a browser also wants to be a DNS forwarder it should not do that by default or give a warning the first time such a "feature" is added to an update and confirm the user wants their browser doing something other than what is expected and what other software was specifically designed to do. This is the kind of nonsense Microsoft does which makes their products bloated, unpredictable, and unreliable.