Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New firefox 63 content blocker is active in ordinary session despite setting "only in private windows"

  • 4 odpovede
  • 1 má tento problém
  • 76 zobrazení
  • Posledná odpoveď od rsbrux

more options

The new content blocker is set by default to block "All Detected Trackers" "Only in private windows". This is exactly the way I would want it. However, instead it blocks "All Detected Trackers" "Always". I do *not* have Firefox set to "Always use private browsing mode". To reproduce the observed behaviour, open the website ubs.com in Firefox 63.0. The shield will display in the address bar. When clicked on, it says "blockable content detected on this site", and some pages on this site do not display correctly.

Všetky odpovede (4)

more options

Hi,

The "blockable content detected on this site" message is just letting you know that there is content that could be blocked, nothing will actually be blocked unless you enable the setting.

However, on the settings page, right underneath the block trackers option, there's also a "block third party cookies set by trackers" option that's always enabled by default. Could you try turning this off and see if that helps?

Also, the website seems to work correctly for me even with tracker blocking enabled - could you provide a link to one of the pages that isn't working for you?

more options

You can check the Web Console for messages about blocked content.

more options

user1929 said

Hi, The "blockable content detected on this site" message is just letting you know that there is content that could be blocked, nothing will actually be blocked unless you enable the setting. However, on the settings page, right underneath the block trackers option, there's also a "block third party cookies set by trackers" option that's always enabled by default. Could you try turning this off and see if that helps? Also, the website seems to work correctly for me even with tracker blocking enabled - could you provide a link to one of the pages that isn't working for you?

I had "Third-Party Cookies" set to block only "Trackers (recommended" not "All third-party cookies (may cause websites to break)". IAC, the site seems to now behave normally. There are 3 possible explanations (in increasing order of probability):

  1. The problem depends on the OS. (I was using Firefox under Linux when I saw the problem, but am now using windows 8.1.)
  2. There was a temporary problem with the website.
  3. I had forgotten to disable uMatrix for the site.

Thanks for your support!

more options

cor-el said

You can check the Web Console for messages about blocked content.

On one of the pages I had trouble with, UBS ETF (LU) MSCI World Socially Responsible UCITS ETF, the web console says "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience." It also still shows a large number of cookies from various sources blocked "because we are blocking all third-party storage access requests and content blocking is enabled". However, as mentioned above, the page seems to work normally now. Thanks for the tip!