Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes Windows after update to 38

  • 3 odpovede
  • 6 má tento problém
  • 666 zobrazení
  • Posledná odpoveď od jscher2000

more options

He, I run Windows 8.1 on a Lenovo Y510P SLI laptop and after the upgrade to 38 launching firefox crashes the whole OS. The screen freezes, the mouse or keyboard are unresponsive, though any sound in the background will keep playing for some more minutes until it stops too and the only thing i can do is hold the power button to force a shutdown. I'm using the latest drivers from Nvidia geforce experiencr from a few days ago and firefox 38.0.5. I tried downloading the developer edition but the situation is similar - i see a very distored ui and if i press the menu button the system freezes. What should i do to fix the issue?

Vybrané riešenie

Can you run Firefox in its Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?


If the problem doesn't occur until you run some Flash media, consider setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

If you don't need Flash, just ignore the notification.


Also, this is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Flash

Right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Any improvement?

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (3)

more options

Vybrané riešenie

Can you run Firefox in its Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?


If the problem doesn't occur until you run some Flash media, consider setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

If you don't need Flash, just ignore the notification.


Also, this is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Flash

Right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Any improvement?

more options

Hello, thanks for the tip for starting Firefox in Safe mode via holding down shift. It appears the whole thing is connected to hardware acceleration for firefox itself. Safe mode worked without any artifacts and I managed to go into the settings and disable it, now all is fine. Does not appear to be flash related, that one has HW Acceleration on and as of writing this post, there's 3 tabs with flash in the background and one in a window right next to this one and there's no stuttering or even slowdown. Maybe it's got something to do with SLI, or the driver version (NVidia WHQL 353.06) but I can't really say. I disabled it for both FF Developer and Firefox 38, both are working just fine. I tried disabling all addons and plugins (Flash incl.), but the moment I ran FF with HW Acceleration on it just froze the whole PC. Maybe it's a good idea to include the 'hold shift to launch Safe mode' in the KB articles, because I didn't see them.

Thanks for the solution!

P.S. Here's a screenshot from FF developer with HW Acceleration I took just before one of the freezes (yes that's the start page)

Upravil(a) Axtroz dňa

more options

Wow, I have to laugh at that screen shot. Definitely hard to use Firefox in that state.

Since hardware acceleration improves the appearance of fonts and animations, you may want to check your computer manufacturer's website to see whether any graphics card/chipset driver updates are available for your system. This article has some further suggestions along those lines: Upgrade your graphics drivers to use hardware acceleration and WebGL.