Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do I shut off the highlighting from the search terms entered?

  • 6 odpovedí
  • 1 má tento problém
  • 1287 zobrazení
  • Posledná odpoveď od discerning

more options

Having multi-color highlighting all over the text in search results is SO distracting. Please, someone tell me how I can shut it off.

Vybrané riešenie

cor-el raises a really good point. Check out the screen shot for the SearchWP extension:

https://addons.mozilla.org/firefox/addon/searchwp/

Edit: I should add that because of changes to the search box in Firefox 34, some older extensions that integrated with the box may behave unpredictably until they are updated.

Čítať túto odpoveď v kontexte 👍 1

All Replies (6)

more options

Do you mean on Startpage.com when you click a link to view the result, instead of going to the actual site, you get the ixquick-proxy page with the highlighting? To turn that off, go into the Settings page for Startpage.com (https://startpage.com/do/preferences.pl) and uncheck the box for "Automatic Highlighting" and then scroll down and click Save Settings.

If that's not it, could you describe where the highlighting is in more detail and/or post a screen shot showing it? This article has tips on screen shots: How do I create a screenshot of my problem? Please blur or delete anything personal or confidential in the screen shot before posting.

more options

You have quite a few extensions installed.

Did you check them for possibly causing this issue?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Vybrané riešenie

cor-el raises a really good point. Check out the screen shot for the SearchWP extension:

https://addons.mozilla.org/firefox/addon/searchwp/

Edit: I should add that because of changes to the search box in Firefox 34, some older extensions that integrated with the box may behave unpredictably until they are updated.

Upravil(a) jscher2000 dňa

more options

I already had automatic highlighting disabled in the StartPage preferences. As you requested, I've included a screenshot of the highlighting problem here with my posted reply. As you can see, I tried changing the default search engine from StartPage to another. First, I made Blekko the default, and removed any checkmarks for any search engines listed as options in the new window that drops down. I did a search and the highlighting still appeared. Then I made Google the default search engine as a test, with checkmarks for all other search engine options removed (that's the test in the screenshot)... and, lo and behold, highlighting was still going on. So the problem may be an add-on to Firefox as another forum helper has suggested. I hope it is that, and not one of the "improvements" Firefox has made. I'll post when I find out more. If you have any more thoughts about the problem, add them to this thread. And thank you very much for your help.

more options

I disabled the SearchWP add-on, and the highlighting problem is gone. Thanks so much... to you, and to cor-el.

more options

Yes, I do have many extensions. And it IS a pain to go through and check when a problem comes up. I had just gone through sorting out a Malwarebytes re-install problem and then had to struggle to get Firefox updated (it required a re-install because I kept getting a "can't install" error and advisement to "check to see if there was another instance of Firefox running." Then I discovered my address box was gone and highlighting all over the place, and searched about what was going on, thinking maybe they were changes with the new version 34 of Firefox. Thank you for the kick in the pants, cor-el, about checking my add-ons, and thanks also to jscher2000 who nailed the right extension, and saved me some time.