Search Support

I have Mac Version 10.5.8 Build 9L31a, Dual 2GhzPower PC05. 2 gb DDR SD RAM but when I try to upgrade from 3.6.24 to the newer version, I receive a message that says my Mac is not compatible. What can I do?

  • 1 ответ
  • 1 имеет эту проблему
  • 484 просмотра
  • Последний ответ от the-edmeister

more options

It appears that I meet the criteria necessary for the upgrade to the latest Mozilla/Firefox. My system does not have Intel. Could that be the reason? Please advise.

All Replies (1)

more options

Firefox 4+ versions aren't compatible with the Power PC architecture, they need an Intel chip.

For older Macs that aren't supported in Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported