Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox spellcheck feature has begun to underline almost all words, regardless of whether words are spelled correctly.

  • 3 ответа
  • 62 имеют эту проблему
  • 20 просмотров
  • Последний ответ от SpellChecker

more options

Firefox spellcheck feature has begun to underline almost all words, regardless of whether words are spelled correctly or not.

Have tried downloading and reinstalling Firefox 3.6.8 but the same thing happens.

Tried different web pages to see if it was a feature of a particular website but it happened even as I typed this entry in a field on a Mozilla website page.

Such a shame, apart from theme extensions the spellchecker is one of my favourite Firefox features!

Выбранное решение

Can you tell which dictionaries were causing that issue?

Only the currently selected dictionary should have effect.

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
Also make sure that [[X]"Check Spelling" in the right-click context menu has a tick.
You can also try to toggle the "Check Spelling" item off and on again.

See http://kb.mozillazine.org/Spell_checking and How do I use the Firefox spell checker?

Прочитайте этот ответ в контексте 👍 4

Все ответы (3)

more options

Fixed by disabling one of the two dictionaries I was using as add-ons. One in a different language had begun to over ride the other . Never been an issue before for me but if anybody else has the same problem you might like to try disabling one of your dictionaries.

more options

Выбранное решение

Can you tell which dictionaries were causing that issue?

Only the currently selected dictionary should have effect.

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
Also make sure that [[X]"Check Spelling" in the right-click context menu has a tick.
You can also try to toggle the "Check Spelling" item off and on again.

See http://kb.mozillazine.org/Spell_checking and How do I use the Firefox spell checker?

more options

Re-enabled the other dictionary and all seems to be working as it should again, including the right click settings described in your reply.

Not sure what happened, but I did clean the registry with a new (trusted) registry cleaning tool about the same time the problem happened. Maybe some sort of registry error as a result.

Anyway, disabling one dictionary, restarting Firefox and re-enabling the dictionary seemed to patch up whatever the glitch was.

The error was inconsistent with both dictionaries, as though spell checking for two different languages was checking separate paragraphs of the same content at the same time.

If it happens again I'll check the right click settings first.