Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Fonts are broken in Firefox

  • 4 ответа
  • 0 имеют эту проблему
  • 1 просмотр
  • Последний ответ от Adam Duckworth

more options

Hello! I installed Firefox about a year ago, and for the entire duration it seems about 60% of the time the default fonts on various websites look weird (bold?). I have tried uninstalling/reinstalling Firefox, clearing the cache, etc. See attached images for examples. Help!

Hello! I installed Firefox about a year ago, and for the entire duration it seems about 60% of the time the default fonts on various websites look weird (bold?). I have tried uninstalling/reinstalling Firefox, clearing the cache, etc. See attached images for examples. Help!
Приложенные скриншоты

Выбранное решение

You likely need to remove the problematic font.

Like I wrote above, you need to check the Fonts tab in the right panel in the Inspector to see what font actually is used because Firefox might be using a different font than specified. If the Fonts tab is hidden, click the Down arrow at the right end.

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

Make sure you allow pages to choose their own fonts as this affects iconic fonts.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the Down arrow at the right end.

Полезно?

more options

I checked, and the "Allow pages to choose their own fonts" option is already checked.

The weird bold font was displayed in the email notification I got about your reply. So I highlighted the text in the email, right-clicked and chose "Inspect", and it is showing "Helvetica Black Cyrillic Bold" as the font (see attachment).

A while ago I was trying to troubleshoot this issue, and I seem to remember running into some information suggesting it may be a problem with Cyrillic fonts. But I have not been able to find a solution.

Полезно?

more options

Выбранное решение

You likely need to remove the problematic font.

Like I wrote above, you need to check the Fonts tab in the right panel in the Inspector to see what font actually is used because Firefox might be using a different font than specified. If the Fonts tab is hidden, click the Down arrow at the right end.

Полезно?

more options

Initially I could not find the Helvetica Black Cyrillic Bold font in my system, but as I went through deleting and reinstalling different styles within the Helvetica font family, there was one called Helvetica Black Condensed that, when I removed it from the fonts and dragged it to my desktop, the name changed to Helvetica Black Cyrillic Bold (??). Removing this font appears to have solved the problem. So thank you!!!

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.