Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Подробнее

Firefox blocking content!?

  • 2 ответа
  • 1 имеет эту проблему
  • 1 просмотр
  • Последний ответ от al.sterner253

more options

When I upload my personal web page some images are missing, link banners won't display. I need to know if mozilla/firefox is censoring my sites and if so WHY? They display fine in other browsers. I used the developer console to identify the issue, seems that firefox is altering the html data to not display the link banner. See attached image.

When I upload my personal web page some images are missing, link banners won't display. I need to know if mozilla/firefox is censoring my sites and if so WHY? They display fine in other browsers. I used the developer console to identify the issue, seems that firefox is altering the html <img> data to not display the link banner. See attached image.
Приложенные скриншоты

Выбранное решение

Firefox wouldn't normally add such a display:none!important; rule to hide an image that has a specific attribute.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) where this happens?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
Прочитайте этот ответ в контексте 👍 1

Все ответы (2)

more options

Выбранное решение

Firefox wouldn't normally add such a display:none!important; rule to hide an image that has a specific attribute.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) where this happens?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Thanks for the reply. I did as you recommended and discovered that it was the uBlock plugin even though it reported that 0% was being blocked.