Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Manage exceptions list is empty, and Allow button does not add a site

  • 11 ответов
  • 0 имеют эту проблему
  • 47 просмотров
  • Последний ответ от Quenchoo

more options

On a late model Dell laptop, there are no domains listed under Exceptions-Cookies and Site Data. When I key in a domain (whether using www., http, https, or just the domain name by itself.) and click on Allow, that website is not added. It's the same as if browser security is stuck on Remove All Websites. With the same Privacy and Security settings on my desktop, I do not have this problem, so it appears not to be a matter of altering particular settings. Short of removing and reloading Firefox on the laptop, which might work but not teach anybody anything, are there suggestions?

On a late model Dell laptop, there are no domains listed under Exceptions-Cookies and Site Data. When I key in a domain (whether using www., http, https, or just the domain name by itself.) and click on Allow, that website is not added. It's the same as if browser security is stuck on Remove All Websites. With the same Privacy and Security settings on my desktop, I do not have this problem, so it appears not to be a matter of altering particular settings. Short of removing and reloading Firefox on the laptop, which might work but not teach anybody anything, are there suggestions?

Изменено Quenchoo

Выбранное решение

Does the same happen if you use "Tools -> Page Info -> Permissions" ?

You aren't using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) ?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Прочитайте этот ответ в контексте 👍 1

Все ответы (11)

more options

Выбранное решение

Does the same happen if you use "Tools -> Page Info -> Permissions" ?

You aren't using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) ?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks for all your help. I was not aware of Permissions, so have never used it. I do not have private browsing mode checked in settings. The problem persists in troubleshoot mode. I am a little wary of a profile change, but I might later get my courage up and try it. I did remove and reinstall Firefox, keeping the prior information. My only theme is Dark, and I have no extensions other than the Facebook block, which I have on the desktop without the subject problem of this post. I did not locate hardware accelerator. The problem persists with no changes. I will continue to look for relevant differences between my working desktop, which can add to Exceptions, and my laptop, which cannot.

more options

Further information: I found and turned off Hardware acceleration, but problem still present. When I click on SAVE in the area for adding exceptions, the entire Exceptions window blinks out, and I have to click back to it to see if the Save worked, which so far it does not. I am not sure how old this problem is because I do not use the laptop a lot, but perhaps several weeks. What would make the entire add Exceptions list window blink out when I click on Save in that window? Could it be some kind of protective blocking move from Windows 11? [Dell laptop, maybe four years old, fully updated etc., no other issues.]

more options

Is there anything reported in the Browser Console that looks related ?

more options

I am not sure if I can specify relevance. In the console, I see two entries, no idea of meaning. Searchsuggestioncontroller found an unexpected string value: HTTP request timeout. Loginhelper(main): Could't parse specified uri (System Principal) with error NS_ERROR_MALFORMED_URI.

more options

Renaming permissions.sqlite in both local and roaming did not solve the problem. When I check the delete cookies button in delete cookies and site data, I find that the cookies box in Clearing history, custom settings, settings for that, is also automatically checked by checking the box in the cookies and site data section. This seems to be faulty because the cookies box in History wipes out exceptions, so there is no point in creating the exception list. Is it correct for checking delete cookies in Cookies and site data to also check the box automatically in History too?

more options

Using "Delete cookies and site data when Firefox is closed" to clear cookies keeps cookies with an allow exception, in 102+ version toggling this setting makes changes to the "Clear history when Firefox closes" settings and those settings prevail if you would make changes there. Using "Clear history when Firefox closes" in Firefox 102+ honors exceptions and keeps cookies with an allow exception, previous versions removed all cookies.

Make sure to keep the "Site settings" as clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings
more options

Thanks once again for all your help. I have done everything you recommended, including just now creating a new profile. When Firefox launched with the new profile, and before I had changed any default settings in Privacy and Security, I was able to add items to the Exceptions list. After I added back my preferred protection, or maybe just after several minutes passed, I once again could not add an item to the Exceptions list. I cannot even see the body of this list, even though I click Allow and then Save. The Exceptions windows never shows the body of that list at all, just the headings for that list. My settings would be suspect, except that these settings cause no problems on the three household desktops, which may or may not be a clue, but it's interesting. My privacy settings are fairly strong: Custom, leave checked Cookies, Tracking Content, Cryptominers, and Fngerprinters. I further select blocking Cross-site tracking cookies, and Isolate other cross-site tracking cookies, and In All Windows. I have these security settings on all three local network PCs, without the problem this laptop has, Dell circa 2018, solid state. When I then remove the security settings, and clear history when Firefox closes, and Remember History, I still cannot add an exception. So it looks like something corrupts the profile when I set up more privacy restrictions, or maybe corrupts right away, just in the passage of time. What is doing that is way beyond my technical knowledge. Creating more profiles sounds exhausting. I am toying with Edge now.....

more options

Adding to the above new post, when I enter a website address intending to add it as an exception, and then click on Allow or one of the other two commands, the entire Exceptions window blinks and disappears. My guess is that this problem is unsolvable right now, and will remain so unless my report is not unique. Whether it is significant that this problem occurs only on my Dell laptop, not on my three local network desktops, is not possible for me to say. If you have other ideas, great, but this may be mission impossible, for now. We tried, hard. On the laptop, I will just use Edge, continue with Firefox on the desktops.

more options

I think the problem is solved now. I was using a dark theme. The dark theme I was not treating as a theme because it was in the main Settings area, and it seemed harmless. I went to white, and when I clicked on Exceptions I now see the full body of the Exceptions list, and I can add to the list. This may be worth reporting, as the dark theme is presented separately, in General, from the main list of themes, which may lead to some people 'not taking it seriously' as a potential problem theme. Maybe graphics were involved, don't know. Thanks again for the guidance. I marked as the solution your post with "theme" in the message.

more options

Cor-el. Well, this is embarrassing: My problem was actually solved by going to the full screen view, which thereby allowed the Exceptions list popup to actually show the list of exceptions. In short, there never was a functional problem with the Exceptions list, just a viewing problem that looked like a functional problem. Apparently, technically there is no way to scroll a popup. This also explains why the problem appeared first and primarily on my laptop's smaller screen, but not on my PC's, except rarely. No list of exceptions was visible because of how the popup worked in normal screen view, cutting off the exceptions list right at the upper part of its column headings. I don't know if Firefox could program any of this differently, and I don't now how many people would be like me confused and frustrated by this situation. I leave that to you, if you are still reading my updated replies. There will be no more of them on this issue.