Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

YouTube videos on Firefox getting slower and jerky.

  • 21 ответ
  • 2 имеют эту проблему
  • 182 просмотра
  • Последний ответ от guidox11

more options

YouTube videos on Firefox getting slower and jerky. After refreshing Firefox (Settings -> Help -> More troubleshooting information -> Refresh Firefox), it is OK, but only for a short while. Then the problem starts again. Same YouTube videos are running fine with Chrome at the same time.

Running Windows 11 Pro (Clean windows setup not long ago and the issue was there from the beginning.) German Language Firefox 116.0.2 Build ID 20230805021307 Intel CPU i7-1360P, 16 GB RAM, 1TB M.2 SSD

Would really appreciate a solution for the issue because I really like Firefox!

YouTube videos on Firefox getting slower and jerky. After refreshing Firefox (Settings -> Help -> More troubleshooting information -> Refresh Firefox), it is OK, but only for a short while. Then the problem starts again. Same YouTube videos are running fine with Chrome at the same time. Running Windows 11 Pro (Clean windows setup not long ago and the issue was there from the beginning.) German Language Firefox 116.0.2 Build ID 20230805021307 Intel CPU i7-1360P, 16 GB RAM, 1TB M.2 SSD Would really appreciate a solution for the issue because I really like Firefox!

Выбранное решение

Looks like the solution for the issue is to change in about:config

     gfx.webrender.compositor = true

to:

     gfx.webrender.compositor = false


I tried it for a few days and the issue is still gone.

Thank you very much @zeroknight

Прочитайте этот ответ в контексте 👍 1

Все ответы (20)

more options

With hardware acceleration disabled, the issue is still there with YouTube Shorts. The normal YouTube videos are working fine. In Troubleshoot Mode normal and YouTube Shorts videos running without an issue. Any ideas what to do?

more options

With updating to Firefox 117 and a new Intel VGA driver found on the Lenovo support web page, the problem is gone without the need for hardware acceleration disabled.

Still wondering why Lenovo Vantage was not updating it automatically or at least telling that there is a new graphic driver is available.

The answer from the Lenovo Support Hotline, why Lenovo Vantage didn't update the driver, was really not satisfying. They said, Lenovo Vantage will only show updates when there is an issue with Software from Lenovo. As Firefox is no Lenovo software, the graphic diver was not automatically updated. That leaves me just speechless. :-(

more options

The issue accured again with the new driver and also with hardware acceleration disabled. With YouTube videos and YouTube shorts.

Same videos are running fine on Chrome.

more options

Does it still happen with h264ify installed?

more options

I did not install h264ify yet. In Thunderbird troubleshoot mode YouTube videos and YouTube Shorts videos running without an issue so far. Do you still think it makes sense to try h264ify?

more options

With Firefox 118 the issue is still there.

more options

Did you try installing h264ify?

more options

I did not try h264ify but I found out something different then before with Firefox 117. When a YouTube video is not loading with 117 reloading did not help. With 118 this is different and the video is loading when reloading is pushed and than running Ok. I will watch for a while if this solves the problem and if the issue will still be there I will try h264ify.

Изменено guidox11

more options

Issue came up again with YouTube shorts not loading. I'm now trying h264ify.

more options

Running h264ify solves the issue but unfortunately limits the resolution. 640x360@25 even when I go to full frame. The same video without h264ify in firefox or on Chrome is shown in 1920x1080@25. That means for me, that is not the solution I want. :-(

more options

The extension blocks: disallowed_types = ['webm', 'vp8', 'vp9', 'av01']; If h264ify-block_60fps is enabled then framerates higher than 30 are blocked.

Note that Firefox has prefs for 'vp8/vp9', search:

  • about:config => *(webm[.]|vp8|vp9)

Изменено cor-el

more options

Youtube allows h264 up to 1080p (DASH) or 720p (non-DASH), these are often 60fps so make sure you don't block that.

Try disabling all other extensions besides h264ify. If you have made any about:config changes related to media you could try resetting them back to default.

more options

I do not have any extension installed in firefox than h264ify. I did no about:config changes. See attchments regarding the different solution on the same video in YouTube h264ify enabled or disabled. Two are full screen an the other two are in the same window size. Please note the difference in the "Optimal Res".

more options

That video plays for me at 1080p with h264ify. Be sure to specify the resolution manually rather than leaving it on Auto mode since h264 requires more bandwidth which can make it slower to buffer.

more options

As I do not like to have to change the resolution manually for every YouTube video, I think the better solution for me is to start Firefox every time in Troubleshoot Mode with h264ify disabled. Normal YouTube videos and YouTube Shorts videos are running without an issue in Troubleshoot Mode.

Then I will wait for a Firefox version without the issue I'm experiencing.

I wonder what the difference is between normal Firefox and Firefox in Troubleshoot Mode.

more options

Troubleshoot Mode disables security features and should not be used for anything other than troubleshooting.

You can use YouTube High Definition to specify your preferred resolution.

Some about:config settings changed in Troubleshoot Mode include:

layers.acceleration.disabled = true gfx.webrender.compositor = false layers.gpu-process.enabled = false

more options

I was not able to find information about any security features disabled in Troubleshoot Mode. Not here: https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode?redirectslug=Safe+Mode&redirectlocale=en-US

Also not here: https://kb.mozillazine.org/Safe_Mode

more options

I found out, that when the issue occurs, and I delete the first of the many Firefox tasks in the Task Manager, the issue is gone. Though it will appear some time later again.

more options

Troubleshoot Mode disables win32k lockdown (equivalent to security.sandbox.content.win32k-disable set to true) which prevents content processes from making dangerous system calls.

https://searchfox.org/mozilla-central/rev/3389de86c4daf28fe402fcfe7d99e8646d41f302/toolkit/xre/nsAppRunner.cpp#771

more options

@zeroknight Do you mean with this:

     Some about:config settings changed in Troubleshoot Mode include:
     layers.acceleration.disabled = true
     gfx.webrender.compositor = false
     layers.gpu-process.enabled = false


Should I try if these settings solve the problem? Or are these examples for possible safety issues in Troubleshoot Mode?

Изменено guidox11

  1. 1
  2. 2