Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Embedded videos have closed captions enabled by default

  • 3 ответа
  • 2 имеют эту проблему
  • 66 просмотров
  • Последний ответ от Nick T

more options

I just got a new phone (Pixel 7a) and embedded videos have closed captions enabled by default in Firefox. Even if I turn them off while watching one video, they'll be back on the next video. I want them to just be off by default. It's not an Android setting as far as I can tell - I have all live captioning turned off and the video player isn't showing captions when I use Chrome to watch the same videos. Here's a link to a video that has captions on by default when I view it in FF for Android. I've also included a screenshot of the CC controls.

I just got a new phone (Pixel 7a) and embedded videos have closed captions enabled by default in Firefox. Even if I turn them off while watching one video, they'll be back on the next video. I want them to just be off by default. It's not an Android setting as far as I can tell - I have all live captioning turned off and the video player isn't showing captions when I use Chrome to watch the same videos. [https://www.reddit.com/r/MadeMeSmile/comments/15o1tqj/meeting_newborn_brother/ Here's a link to a video that has captions on by default when I view it in FF for Android.] I've also included a screenshot of the CC controls.
Приложенные скриншоты

Выбранное решение

I've found a workaround. By adding *.vtt to the My Filters section of uBlock Origin, it blocks all calls for captions and the button isn't displayed on the player.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options
more options

I also have this issue, but on the desktop version. All I found online was about the picture in picture mode, even though that is disabled for me. I even tried setting "media.videocontrols.picture-in-picture.display-text-tracks.enabled" to false, but that didn't help. I need to go to every new video, right click on "Show controls" then set the CC to off and that got very tiring very quick. Is there an option we can set to have the CC off by default? I sure hope there is!

more options

Выбранное решение

I've found a workaround. By adding *.vtt to the My Filters section of uBlock Origin, it blocks all calls for captions and the button isn't displayed on the player.