Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Can't get policies.json working on Kubuntu 20.0.04

  • 8 ответов
  • 1 имеет эту проблему
  • 12 просмотров
  • Последний ответ от mdiehl

more options

Hi all,

I'm trying to automatically configure Firefox using the policies.json file, but I don't seem to be able to get it to work.

I've created /usr/lib/firefox/distribution/policies.json with this content: {

 "policies": {
   "Homepage": {
     "URL": "https://www.google.com/",
     "Locked": false,
     "StartPage": "homepage"
   }
 }

}

The file and directory permissions allow for read by everyone.

However, when I restart Firefox, I don't get google as my homepage.

What else can I check?

TIA,

Mike.

Все ответы (8)

more options

policiesStatus: 1; in the troubleshooting information would suggest the policies are active.

You can check the about:policies page (63+) to see whether policies are active and whether errors are reported.

Полезно?

more options

Hi again,

I noticed the policiesStatus: 1 line and inferred that it meant that the policy was in place. But, even after restarting Firefox, I didn't see the effects of the policy.

I was expecting that the hope page would point to google, but that's not what I saw.

Mike.

Полезно?

more options

What does about:policies show ?

Полезно?

more options

Well, about:policies indicates that I've done it right. See attached image.

Perhaps this setting doesn't do what I think it does...

I'm just wanting to set the home page to google. Am I missing something?

Mike.

Полезно?

more options

Maybe Ubuntu overrides the policies.json file with its own policies since you are using Firefox from the Ubuntu repositories.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Полезно?

more options

OK, I extracted the firefox runtime from the website that you linked to. Then, I created the ./distrubtion/policies.json file, as before.

Only, this time, I see google as my homepage! Yay!

So, I guess the next question is how is ubuntu overriding my policies? Is that a question for this forum? Or do I need to go to ubuntu, now?

Thanks again,

Mike.

Полезно?

more options

You can try to ask/search at Ubuntu support.

Ubuntu might be using a location like this: /etc/firefox/

Полезно?

more options

I appreciate your time. I have posted a query to the kubuntu support forum.

Thank you,

Mike.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.