Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

YouTube Livestreams in 1440p+

  • 5 ответов
  • 1 имеет эту проблему
  • 4 просмотра
  • Последний ответ от jscher2000

more options

Hey!

So I want to watch livestreams on YouTube (Overwatch League to be more precise). The problem is, that the stream starts to lag really hard when I watch it on 1080p or higher. I don't have that problem with videos, just with livestreams and my PC is not bad, my CPU, RAM or GPU are not even close to their limit as far as I can tell. Still, it doesn't work in Firefox but it does in Microsoft Edge. I definitely prefer Firefox over Edge but right now I have to use Edge to watch streams in HD+. I already came across a solution from 2019 where it said I need to install an addon, which would fix the problem but limits the quality to 1080p (https://support.mozilla.org/de/questions/1245735). However I thought maybe two years later there is a solution that allows me to watch streams in 2K and I mean Edge makes it possible too so I figured I'd just ask.

Thanks for your time Noah

Все ответы (5)

more options

Hi Noah, I don't know whether it is still an issue, but in the past, Firefox wasn't able to use the GPU for WebM VP9 encoded streams, which YouTube tends to use for the higher resolutions, and they had to run on the main CPU, which is not optimal. This could vary depending on your graphics hardware (Intel vs. Nvidia vs. AMD, etc.). I'm definitely not a specialist in that area.

Полезно?

more options

Hey,

thanks for your reply! Sadly this does not fix my problem and as I said I am sure my hardware is not the issue. My specs: Intel Core i7-8700 CPU @ 3.20 GHz 16 GB RAM NVIDIA GeForce GTX 1060 6GB 130-250Mbps download, 10-20Mbps upload While trying to watch a YouTube video/livestream the CPU is at about 14%, the RAM at 38%, and the GPU at 11% of its capacity. My internet connection can't be the problem either and as I said, everything works fine in Microsoft Edge. As mentioned above I want to thank you for your response but it does not really help me with solving the problem. I tried everything I found on this website regarding the topic but nothing worked. Is there any way I can fix this issue? Because otherwise, I will have to use another browser, which is not what I want.

Thanks, Noah

Полезно?

more options

Hi Noah, I'm not saying your hardware is the issue. The issue was/is how Firefox uses (or doesn't use) it.

There's a feature of the YouTube player called Stats for Nerds available on the right-click context menu. You can use this to call up details on the stream such as resolution and codec. If you notice a pattern of problem codecs, that could be a clue.

Here's a random example:

Полезно?

more options

Hey,

thanks for the clarification! I am not sure what I have to look for but I recorded two different videos and uploaded the results, I would appreciate if you could check them out, maybe you can figure out the problem. https://youtu.be/g2hic1D8-p4 https://youtu.be/R-vibZy_0B8 I did not pause either of the videos at any point, i just skipped forwards at one point in the second video after it stopped playing and kept loading for some time.

Полезно?

more options

Hmm, the Google stats don't show much of a problem with the player, the problem seems to be in getting the audio/video to the output devices, or perhaps in decoding. I don't know whether there is a way to spy on what Firefox is doing in that regard.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.