Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Display of pages

  • 1 ответ
  • 1 имеет эту проблему
  • 8 просмотров
  • Последний ответ от jscher2000

more options

Several Hompages are not displayed correctly Instaed of showing normal text in the navigation-area is the botton overwritten with text in english. Thank you for support

Приложенные скриншоты

Выбранное решение

Hi Peter, that problem is caused by the iconic Google font "Material Icons" not loading, so alternate text is displaying instead. In the attached screenshot, you can see the word "alarm" in the page code and how it is replaced with a clock icon when the font is loaded.

The file comes from: https://fonts.gstatic.com/s/materialicons/v80/flUhRq6tzZclQEJ-Vdg-IuiaDsNc.woff2

Here are some of the reasons the font file might not be loading:

(1) Firefox set to always use your preferred fonts instead of the fonts specified by the page (2) Font downloading blocked in about:config (3) Font downloading ("remote fonts" or "web fonts") blocked in an add-on (4) Google sites like gstatic.com blocked from being used in non-Google pages

For #1:

Open the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2:

You can check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference has a value of false, double-click it to restore the default value of true

For #3:

For example, uBlock Origin has a setting to block remote fonts. I'm not sure about others.

For #4:

If you use add-ons or container tabs to restrict where Google addresses load, you might need to make an exception.

Прочитайте этот ответ в контексте 👍 1

Все ответы (1)

more options

Выбранное решение

Hi Peter, that problem is caused by the iconic Google font "Material Icons" not loading, so alternate text is displaying instead. In the attached screenshot, you can see the word "alarm" in the page code and how it is replaced with a clock icon when the font is loaded.

The file comes from: https://fonts.gstatic.com/s/materialicons/v80/flUhRq6tzZclQEJ-Vdg-IuiaDsNc.woff2

Here are some of the reasons the font file might not be loading:

(1) Firefox set to always use your preferred fonts instead of the fonts specified by the page (2) Font downloading blocked in about:config (3) Font downloading ("remote fonts" or "web fonts") blocked in an add-on (4) Google sites like gstatic.com blocked from being used in non-Google pages

For #1:

Open the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2:

You can check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference has a value of false, double-click it to restore the default value of true

For #3:

For example, uBlock Origin has a setting to block remote fonts. I'm not sure about others.

For #4:

If you use add-ons or container tabs to restrict where Google addresses load, you might need to make an exception.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.