Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Random Black Theme without Addons

  • 5 ответов
  • 2 имеют эту проблему
  • 26 просмотров
  • Последний ответ от vivanco987

more options

Hi, can i somehow see which addons affect a currently open site? only with Firefox connected to my Sync a specific website turns darkmode and is almost unusable, i already started firefox in save mode without addons, the site is still dark

sadly i cant post the website because its only reachable via Company login, it is a Normal website from a multi million dollar company and its normal on every other Computer except mine

Выбранное решение

Could you check these color settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste color and pause while the list is filtered

(3) If the browser.display.background_color preference is bolded and has a left-arching reset arrow button at the far end of the bar, click the button to restore the default value (usually #FFFFFF for white)

(4) If the browser.display.foreground_color preference is bolded and has a left-arching reset arrow button at the far end of the bar, click the button to restore the default value (usually #000000 for black)

(5) To set Firefox to strictly honor page colors, double-click the browser.display.document_color_use preference to display an editing field, and change the value to 1 then press Enter or click the blue check mark button to save the change. (This corresponds to setting "Override the colors specified by the page with your selections above" in the Colors dialog on the Options page to "Never")

Any difference the next time to visit the problem site?

Прочитайте этот ответ в контексте 👍 1

Все ответы (5)

more options

Based on the Safe Mode test, it doesn't sound like an add-on is causing it.

Does your Windows use a dark theme? Sites can query Firefox about whether your system uses a light or dark theme and modify their appearance in response to that. There is a preference you can create to override the system theme so Firefox always reports to site what you want. Here's how to set that up:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box, type or paste ui.systemUsesDarkTheme

(C) Firefox should display a bar with some radio buttons to choose a new preference type, followed by a + button. Choose Number and click the + button:

(D) Edit the value to either 0 (Light) or 1 (Dark) and then click the blue check mark button or press Enter/Return to save the change.

Any difference the next time you visit the problem site?

Possibly you might need to clear cache and cookies, too, if it has stored a dark mode preference:

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just select web cache, not all site data)

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page and logging in again.

Does that help?

Полезно?

more options

jscher2000 said

Based on the Safe Mode test, it doesn't sound like an add-on is causing it. Does your Windows use a dark theme? Sites can query Firefox about whether your system uses a light or dark theme and modify their appearance in response to that. There is a preference you can create to override the system theme so Firefox always reports to site what you want. Here's how to set that up: (A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (B) In the search box, type or paste ui.systemUsesDarkTheme (C) Firefox should display a bar with some radio buttons to choose a new preference type, followed by a + button. Choose Number and click the + button: (D) Edit the value to either 0 (Light) or 1 (Dark) and then click the blue check mark button or press Enter/Return to save the change. Any difference the next time you visit the problem site? Possibly you might need to clear cache and cookies, too, if it has stored a dark mode preference: (1) Clear Firefox's Cache See: How to clear the Firefox cache (just select web cache, not all site data) If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page and logging in again. Does that help?

thank you ill try that

Полезно?

more options

Sadly that didnt help, the site is still black and mostly anreadable

Полезно?

more options

Выбранное решение

Could you check these color settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste color and pause while the list is filtered

(3) If the browser.display.background_color preference is bolded and has a left-arching reset arrow button at the far end of the bar, click the button to restore the default value (usually #FFFFFF for white)

(4) If the browser.display.foreground_color preference is bolded and has a left-arching reset arrow button at the far end of the bar, click the button to restore the default value (usually #000000 for black)

(5) To set Firefox to strictly honor page colors, double-click the browser.display.document_color_use preference to display an editing field, and change the value to 1 then press Enter or click the blue check mark button to save the change. (This corresponds to setting "Override the colors specified by the page with your selections above" in the Colors dialog on the Options page to "Never")

Any difference the next time to visit the problem site?

Полезно?

more options

jscher2000 said

Could you check these color settings: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste color and pause while the list is filtered (3) If the browser.display.background_color preference is bolded and has a left-arching reset arrow button at the far end of the bar, click the button to restore the default value (usually #FFFFFF for white) (4) If the browser.display.foreground_color preference is bolded and has a left-arching reset arrow button at the far end of the bar, click the button to restore the default value (usually #000000 for black) (5) To set Firefox to strictly honor page colors, double-click the browser.display.document_color_use preference to display an editing field, and change the value to 1 then press Enter or click the blue check mark button to save the change. (This corresponds to setting "Override the colors specified by the page with your selections above" in the Colors dialog on the Options page to "Never") Any difference the next time to visit the problem site?

Thank you that did it!!!! it was set to #000000 and resetting it put it to FFFFFFFFF and when i put it on 1 now my site is finaly readable :)

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.