Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Firefox always starts in private window; never remembers history

  • 4 ответа
  • 1 имеет эту проблему
  • 13 просмотров
  • Последний ответ от jim.ackermann

more options

I am trying to help my daughter figure out a problem she has with Firefox on her Windows 10 laptop. She has the latest version of Firefox installed.

Every time she starts Firefox, it starts in a private window. Even after closing it and opening a "normal" window, the choice to open the tabs from the last session is dimmed. There is no history.

I have checked her privacy and security settings and it's at the default position. It is not set to open in a private window, and it is not set to forget history.

I am baffled!

Выбранное решение

Check the shortcut being used to start Firefox.

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

Выбранное решение

Check the shortcut being used to start Firefox.

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Полезно?

more options

I apologize for taking so long to reply. My daughter starts online teaching next week, so access to her computer to try making your suggested changes has been limited to say the least! I did get to enter the settings changes yesterday (I think they are pretty much what I have tried, except for the turning off of everything but the Cache and Form and Search History). I also deleted her taskbar icon and created a new one after making the settings changes. I think that might be what you meant about the shortcut.

We have not tried quitting and restarting Firefox yet, though. She has too many tabs open and, if this doesn't work, does not want to re-create her environment. I will have to wait till sometime later. But I will be sure to let you know if it worked!

Thanks again.

Полезно?

more options

One option for saving open tabs is to use the Bookmark All Tabs feature. On Mac, try Command+Shift+D to call that up, and Firefox should offer to bookmark all of the open pages in the current window to a new folder. This only captures the current URL and not the tab's back/forward history.

Also or alternately, one or more of these session management add-ons that can save the open tabs might work in private windows:

Use database storage:

Use bookmark storage:

Bookmark storage is more robust in that Firefox backs it up regularly. However, having the extra data show up when you are searching your bookmarks may be annoying.

Полезно?

more options

My daughter finally was forced by a system update to restart her laptop. It looks like the settings suggested by FredMcD solved the problem as Firefox is now re-opening by re-establishing the old session rather than in a private window, with no history. Thanks!

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.