Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Is there a way to keep websites from inflicting autoscroll, smooth scrolling, migraines?

  • 5 ответов
  • 1 имеет эту проблему
  • 17 просмотров
  • Последний ответ от MarjaE

more options

I have a visual motion sensitivity, and autoscroll and smooth scrolling are among my many migraine triggers.

I already use the settings in both Firefox and Waterfox to keep the browsers from inflicting autoscroll or smooth scrolling. But some sites have their own special code to convert regular scrolling or page up/page down into autoscroll.

I have looked in the add-ons list, but I see many tools for users who want autoscroll and/or smooth scrolling on certain sites, and can't find any tools to protect against autoscroll and smooth scrolling.

Is there something I've overlooked?

Thanks.

I have a visual motion sensitivity, and autoscroll and smooth scrolling are among my many migraine triggers. I already use the settings in both Firefox and Waterfox to keep the browsers from inflicting autoscroll or smooth scrolling. But some sites have their own special code to convert regular scrolling or page up/page down into autoscroll. I have looked in the add-ons list, but I see many tools for users who want autoscroll and/or smooth scrolling on certain sites, and can't find any tools to protect against autoscroll and smooth scrolling. Is there something I've overlooked? Thanks.

Все ответы (5)

more options

Have you checked your mouse driver setting for the scroll functions control.

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

https://www.nytimes.com/interactive/2019/06/11/us/elections/results-virginia-primary-election.html

I use scrolling software (Scroll+ for the Mac) and mouse software (the Evoluent extension) but that doesn't explain why certain pages jack the page up and page down buttons. I get the same behavior using the ones on my keyboard instead of the ones on my mouse.

more options

You may have switched on caret browsing.

You can toggle caret browsing off/on by pressing F7 (Mac: fn + F7).

  • Options/Preferences -> General: Browsing
    remove checkmark: [ ] "Always use the cursor keys to navigate within pages"

Note that this is a Firefox accessibility feature.

more options

No, not caret browsing.

But using caret browsing doesn't affect page up or page down. If it was normal, it stays normal. If it was hijacked for animated scrolling or page flips or the like, it stays jacked.