Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

iframe not working in FF quantum when embedding http (works with https

  • 4 ответа
  • 23 имеют эту проблему
  • 12933 просмотра
  • Последний ответ от cor-el

more options

This code not working in Quantum: <iframe src=

     "http://www.antique-microscopes.com/photos/grand.pdf" height=
     "900" width="700"></iframe>


All I see is a blank box. See this link: http://www.antique-microscopes.com/photos/Grand_model_microscope.htm

It works in Safari, Chrome, and earlier FF versions. I note that if I try to embed from a https site, it does work. Is there a work around for this other than making my site https?

Выбранное решение

Works fine here. I see that iframe at the bottom of the page and can use its scroll bar to scroll these images.

Did you check for (security related) messages in the Web Console?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version
Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

I am not sure what your problem is, as your site is working fine when I look at it with my Firefox Quantum under Windows 10 Pro (see snapshot).

It would be helpful if you could provide some more information on your installation, please. Which OS? Is it a clean new install, or if an upgrade from earlier Firefox, do you remember which version? Thanks.

Изменено RichardInEngland

more options

You should be able to embed HTTP in HTTP; there will be a mixed content error if you embed HTTP into HTTPS.

If you right-click (or on a one-button mouse Ctrl+click) the blank area, click This Frame, then Open Frame in New Tab, does the PDF load there?

What is your PDF viewer? Are you using Firefox's built-in viewer, or something else?

more options

Thank you both for the responses The problem is solved for me. Apparently, when I upgraded to Quantum, the default to view pdf documents in FF was not enabled. Enabling this solved the issue for me. However, I wonder about the viewers to my website. If they haven't enabled this option, they see a blank frame when using FF.

I can solve this issue by converting my few pdf documents to html.

more options

Выбранное решение

Works fine here. I see that iframe at the bottom of the page and can use its scroll bar to scroll these images.

Did you check for (security related) messages in the Web Console?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version