Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

About a week ago Weather.com stopped working on Firefox but is OK with Safari.

  • 11 ответов
  • 7 имеют эту проблему
  • 3247 просмотров
  • Последний ответ от gaia1muse

more options

Since the last week of March 2016, weather.com stopped working. All I get is a single window with most of the banner blacked out. Selecting from the drop downs bring mostly empty screens or, in the case of Today's forecast, Page not found. I updated to El Capitan hoping that would solve the issue. No luck. I'm at Firefox 45.0.1 which says it's up to date. What happened?

Выбранное решение

Several users have reported that weather.com does not load fully if you have completely disabled location services. You can check on that here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste geo and pause while the list is filtered

(3) If the geo.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

(4) Switch over to weather.com and test, and prepare for getting annoying permission requests...

You can make permanent site-specific location permission changes using the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click (Ctrl+click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find "Access Your Location" and you can uncheck the "Use default" box and select the permission you prefer.

Note: If you have Firefox set to clear history when you close Firefox, make sure not to clear "Site Preferences" or your permissions will be deleted.

Прочитайте этот ответ в контексте 👍 1

Все ответы (11)

more options

Выбранное решение

Several users have reported that weather.com does not load fully if you have completely disabled location services. You can check on that here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste geo and pause while the list is filtered

(3) If the geo.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

(4) Switch over to weather.com and test, and prepare for getting annoying permission requests...

You can make permanent site-specific location permission changes using the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click (Ctrl+click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find "Access Your Location" and you can uncheck the "Use default" box and select the permission you prefer.

Note: If you have Firefox set to clear history when you close Firefox, make sure not to clear "Site Preferences" or your permissions will be deleted.

more options

I have this problem too (also starting in late March). Since I do not want geo tracking enabled for all sites, I first tried this solution: "You can make permanent site-specific location permission changes using the Permissions panel of the Page Info dialog. You can call that up using: "right-click a blank area of the page and choose View Page Info > Permissions Uncheck the "Use default" box and select the permission you prefer."

It did not work; on weather.com most of the page would not fill in; if I clicked on Allergy Tracker, I got an "Oh No! This page does not exist; Go Back!"

I then turned on geo tracker, following the instructions in the chosen solution. That did make weather.com work perfectly. However, I would rather not be tracked by all web sites, so can anyone tell me why changing the setting for ONLY weather.com did not work - or another way to allow only weather.com to track my location?

more options

I do have a user.js file and have no idea what all those lines that start with "user_pref("extensions.delta." mean. I've read that this file can be deleted, but I don't know whether that will undo some of my settings in Firefox. Could this be the reason that changing the preferences on the weather.com page did not allow the rest of the page to load?

more options

You would have to reset preferences set via user.js manually on the about:config page or delete prefs.js as well to reset all prefs.

more options

Hi NanCcan, until you set a different permission, Firefox will ask whether the current site requesting your location is allowed to access it. Just say no for the sites you do not want to access your location. (There may be several annoying prompts at first, but they should go down over time as Firefox stores up your decisions.)

more options

"Just say no for the sites you do not want to access your location. (There may be several annoying prompts at first, but they should go down over time as Firefox stores up your decisions.)"

Thanks! I'll try that. I didn't know Firefox could "learn" this site-by-site.

more options

Oops...my problem was solved with the geo activation so I deleted the other solution emails.. But I don't like the idea of my location being out there for all sites. Can someone spell out, in understandable detail, how I can selectively allow access (without jeopardizing my system through stupid mistakes)

Thank you

more options

Hi NatureGirl, that's what I was saying to the other poster. Sites need your permission to access location information, so when a site asks for it, then Firefox will drop down that panel for your approval/disapproval.

more options

But how do I make the necessary modifications to undo the geo change and then the other modification that will cause Firefox to drop down the panel for approval? And then Firefox will remember that approval and give me access to ALL the panels on weather.com? I noticed that one user with the same issue said the js(?) solution didn't totally solve the problem.

Am I going to be stuck allowing all site access to my location in order to have full access to weather.com?

more options

Hi NatureGirl, if you have geo.enabled set to true, you're all done.

When you get to a site that wants to access your location, if you have not already set the site's permission on a previous visit, Firefox will display a panel asking whether you want to grant permission. For example:

http://www.mapdevelopers.com/what-is-my-address.php

Your choices are:

  • Share now (does not set a permanent permission)
  • Using the triangle next to the button:
    • Always share
    • Never share
    • Do not share now (does not set a permanent permission)
more options

I tried all of the above and none worked. Finally went back to basics and removed all weather.com cookies.... It's working fine now.

>Tools >Options >Privacy >Remove individual cookies Search for weather.com Select and delete all weather.com