Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Named anchors in (i)frames aren't jumped to

  • 5 odpowiedzi
  • 57 osób ma ten problem
  • 986 wyświetleń
  • Ostatnia odpowiedź od jsudhish

more options

When a website contains named anchors and that site is loaded in an (i)frame (only tested in iframe) FireFox 4 denies to jump to the content if a link inside that frame links to the named part.

When a website contains named anchors and that site is loaded in an (i)frame (only tested in iframe) FireFox 4 denies to jump to the content if a link inside that frame links to the named part.

Wszystkie odpowiedzi (5)

more options

Make sure your named anchors to not contain "#" which would only be used in the link not in named anchors nor in id.

more options

It's specifically about the "Beschreibung" anchor. I link to it with <a href="#Beschreibung">Beschreibung</a>

and further down there is a <a name="Beschreibung"> </a>

It works in IE, Chrome and Safari, just not FireFox.

more options

That is this bug Bug 638598 - Iframe parent window page does not scroll to # anchor by user interaction

more options

Are all of you having this problem on eBay or any page that has iframes? See this link here: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=170658617865

The blue tabs at the top of the auction's description that say "payment" "shipping" "contact us" and "checkout" are all using anchors but they do not work in Firefox. eBay uses iframes for the auction's description so that explains why I'm having the same problem.

more options

Yes I have the same problem on eBay.

Because the Item details on eBay get listed into a IFrame for a Auctiva listed page. And then I have created named anchor links to different named sections headers anchor link of the page. and links for them at the top.

None of them work

You can see that happening, when you open any product item in the store

http://stores.ebay.com.au/JazzY-Bazzar

Do Note not in the store page, but in the every item which is in the store when opened, has href named anchor links, which are failing to work. They work with FF 3.0 as well with IE, but is failing with FF6